No Firmware Available

I am testing a code today. I have 3 electrons in my dashboard, none of them are on or connected. All I wanted to do was compile the code and check for errors. When I click on the verify icon I see compiling code… at the bottom of the screen. Then I get a message that says
Error: 404. Please try again later. If the issue persists, please report to
then back to
Based on a previous issue I had the other day, I decided to check the firmware in the devices tab. Although I see
On the device: 0.4.8
In the building with Firmware: field I see
No firmware available
I tried clearing the cache, logging out and logging back in to no avail.
Can anyone tell me what is going on here please?

Also getting a 404 when trying to go to my console

Has this cleared up for you? There was some maintenance a few hours back.

Thanks for your reply. I just checked it again and no sir. I am still getting a 404 in both the web IDE and when I try to go to the console page.
Thanks for your reply

What do you see at

Can you check what device and firmware you got selected in


Could you try an incognito session, to make sure it isn’t a caching issue or something like that?

It just says No Firmware Available and there is nothing to select in the drop down menu

I will try it again. I did earlier based on the other post that I read with firmware 0.6.2 I think it was?


That’s rather odd - we can see the pages.
Could you try another browser (e.g. Chrome) or another machine?

Ill try Firefox or IE on the same machine. If that doesnt work Ill fire up the laptop and hotspot it to my phone. Ill report back here in a few minutes.

FireFox should work, IE not always - Chrome does in most cases best.

I usually only use Chrome, Thanks for the tip

On Firefox on the same machine I now got

Everything was working great last night. I finished late and left the PC on, then Windows did an automatic update. I woke up this morning and had to re-open everything., FYI

This is the message I got trying to log in to the console, PC, Chrome browser

Possibly repeating things you’ve already done

  • press CLEAR CACHE in the settings drawer of Build
  • clear your browser cache
  • clear DNS cache (if you can - e.g. via CCleaner)
  • restart computer
  • test again
  • same result throw out of window :wink:

No worries, Ill try them all again while I get the laptop set up

@jackpot, I just validated several apps on the IDE with a Photon target and a 0.6.0-rc.2 firmware target and had no problems. I was using Chrome 50.0.2661.102 m.