Download firmware binary not working?[FIXED]

Is the download firmware binary in the code section not working? I cant get it to download. I tried firefox/safari/chromium.

Anyone else having issues?

Hmm… Strange, neither Chrome or Opera work here. Time to call in the help troops: @jgoggins, @Dave?

Hmm, I’m noticing this too, looking into it now.

edit: I think I found it, testing the fix for it…

Thanks!
David

1 Like

Okay, found it and fixed it, going to deploy the fix asap.

2 Likes

Fixed!

Thanks for reporting this and pinging us! :slight_smile:

Thanks,
David

3 Likes

Yup, seems to be working again. Thanks for your quick response, as always ;)!

1 Like

Yep. Works! Thanks @Dave

1 Like

I am now having this issue… I click the “Compile and download firmware binary” button, it saves, verifies, but then just gets stuck in a loading loop saying “waiting for api.particle.io” with no prompt or download occurring. I’ve tried on Chrome and Firefox. Any ideas?

Hi @sddw,

Hmm… Are you seeing any errors on your browser’s “javascript console”? Just so I’m on the same page, what page are you looking at? :slight_smile:

Thanks,
David

Hi @Dave, the only console error I am seeing occurs right when I log in to build.particle.io when it shows:

"The connection to wss://launch-counter-production.herokuapp.com/socket.io/1/websocket/aMdmciO7aIUiMd-uYYAh was interrupted while the page was loading."

When I click on my application name, then click on the download binary icon (cloud with downward arrow), it looks like it is hanging on a GET request to api.particle.io

Does this info help?

Thanks,
Mike

FYI, I just tried it in IE 11, still not working but I got a couple errors in the console:

And on another attempt:

Hi @sddw,

Hmmmmmmm. That might be a bug, checking on that. Thanks for the extra info! :slight_smile:

Thanks,
David

Hi @sddw,

Okay, try it now. :slight_smile: Sorry about that!

Thanks,
David

It worked! What was wrong?

Thanks!