Is anyone else getting timed out when flashing from the Web IDE?

I have an Argon that I was testing and configuring and now I can’t flash it from the IDE or send it Particle.function commands. However, it is still publishing and sending data to my spreadsheet. I even reset and it still is in the same status.

I’m not sure what it was. I started in safe-mode and it fixed it. Everything is running normally now.

1 Like

If someone has an issue in flashing a device, the first thing I ask them to do is to put it into Safe mode. There are lots of things you can do in code that will interfere with flashing.


I should have tried that first before posting on here.

Did it work?



An interesting behavior here:

When flashing Argons from the web IDE, about half the time, I get a message that flashing failed, and within a few seconds of getting that message, the Argon LED goes magenta as part of it’s flashing sequence. It then completes the flash and reboot and behaves as if nothing odd happened during the flash.

I also find that there are large differences between the length of time for a noticeable reaction from the mesh devices from one flash to the next, sometimes going close to immediate after telling the IDE to flash them and seeing the action on the RGB LED. Other times it take so long that I think it did not flash. Also after a flash has begun, I will often see it return back to breathing cyan, with only some very slight occasional brief dimming of the led before I see it go thru the normal LED sequence. I don’t see these variances with the Gen 2 devices.

I have seen what you describe in your first paragraph a few times – not often though.

Now, this is definitely a W.A.G. but I wonder if the variance has to do with the quality of the overall connection with the Particle cloud, since everything is over UDP.

Sometimes after I reset a mesh’s gateway device, it will come online but the endpoints will all flash red simultaneously (but not always) and I’ve wondered if it’s the same thing – a failed authentication handshake because some bits got lost along the way, and so it retries. They always eventually come on-line.