USB issues seeing device

I do not see my Photon on /dev/tty.* as I used to.

Photon f/w: 2.3.0
particle-cli: 3.1.0
macos: 12.2.1
shell: zsh
connection: I cannot bypass a hub here as my mac only has USB-C ports and I do not have a µB <–> C cable. I have tried multiple hubs and cables however.

Obviously particle-cli nor dfu-util sees my device.

I used to be able to see the /dev/tty.usbmodem*
Is there an issue with the Monterey drivers?

There is no known problem with that combination. I flashed 2.3.0 to a Photon and tested Monterey 12.2.1 and it worked properly:

% ls -l /dev/tty.usb*            
crw-rw-rw-  1 root  wheel  0x9000006 Mar  7 17:12 /dev/tty.usbmodem1414201

Does anything show up with:

ioreg -p IOUSB -n Photon

Not sure if you’re on M1 mac or not, but it all works properly on my M1 running Monterey over the apple USB C adapter to a photon.

Probably a stupid question, but have you confirmed that the device is in serial mode? Do you have a different photon you can try to rule out any device issues?

1 Like