Particle CLI not seeing devices on USB (ubuntu and macos)

Wanted to update wifi credentials on some old Photon and Argon devices, and so I thought I'd use my trusty particle CLI with particle serial wifi to update those settings.
However, when I plugged my device into my old Mac, I found that particle usb list showed no connected devices. I tried particle update-cli and then tried particle usb list again with no luck.
I tried placing the devices into various alternate modes (listening, DFU) with no change.
I rebooted the mac, plugged/unplugged the particle devices with no luck.
I tried installing the CLI fresh onto another mac laptop and then onto an ubuntu linux machine. Again, these machines were unable to see the particle devices connected via USB. I was able to verify that the CLI was installed properly by running particle login and then particle whoami.
CLI version from particle version is 3.22.0

Strangely lsusb running on the linux machine (or System Information running on the mac) does not show the argon or photon devices. This makes me wonder whether there's a newly introduced OS incompatibility between the Particle devices and the usb stack on macos and ubuntu.

For what it's worth I believe the Argons have device OS 4.2.0 installed.

Thanks for any help!

You tested the obvious things, and if lsusb can't see the devices in either DFU mode or regular mode, the Particle devices are probably really not visible to the computer.

I know this sounds silly, but are you sure the Micro USB cable you are using isn't a power-only USB cable? That's the exact behavior you would see.

Most Particle employees have Macs, so we probably would have noticed an incompatibility.

1 Like

Thanks for the quick reply. Turns out I was using a short white micro-usb cable that I assumed was an original Particle usb cable, but it was not. :person_facepalming:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.