Is there a USB3 or El Capitan issue with particle-cli? (solved-bad cable)

Hi, trying to determine if there are issues with USB3 ports (on a mac). I was able to use this with photon-cli (node v0.12) on an older iMac USB2 ports, but can’t yet get it to recognize anything connected to my newish MacBookPro USB3 ports.

The working mac USB2, and the non working USB3 are both El Capitan. There are no errors. Both have node v0.12 installed via brew, both have the particle-cli tool installed via npm, and the node-serialport seemed to compile. I can use particle-cli on both machines to ‘particle list’ and it shows the particle device connected to the cloud. But only on the USB2 machine will ‘particle serial list’ work. On the USB3 machine I get the message ‘No devices available via serial’. The port(s) do work. I have programmed an Arduino from their IDE through it.

I don’t have a USB hub to try that method.

Does anyone know if USB3 or El Capitan (or the combo) has given people problems?


Hi @Cward

I have not updated my Mac to El Capitan as of yet, however I have used the USB3 ports on my mac book through the Particle-CLI allot with no issues. Sounds like it may be an El Capitan issue. I plan on updating my OS this evening, will test Particle CLI then and let you know if I have any issues.

Hmmm. I was going to say that it was working okay for me, but then I realized that the last time I communicated with my Particle devices via USB might have been before I upgraded to El Capitan.

Sure enough, I find today that with either a Core or my Photon plugged in, I get “no devices available” from particle serial identify.

I tried a couple of things that I found, but they didn’t help.

It’s working for me on my Early-2015 13" MacBook Pro running El Capitan.

Well, the machine that is working turns out to only be on Yosemite. Could have sworn I updated it too. So the machine that isn’t working is a different version of USB and OSX.

I am not sure whether to be mad or embarrassed. I thought I had checked using a different cable, but I suppose I could have had a different library out of alignment then. With the cable switch it is working: node: 0.12.7, serialport: 2.0.1, particle-cli: 1.8.11

It appears that some cables only carry the power lines for changers and battery packs. I found one that supports data it would appear.

1 Like

I have this issue too… Not working with elcap.

Do you have errors? Or the no serial devices message? One thing that finally helped me out was the OSX command
ioreg -p IOUSB
Which will tell you all the USB devices. Run it once before plugging in the Photon, then again after. Does it show up? At least then you will know if El Cap can see it.

Will try this… Thanks for the advice!

I get a no device found.

I have been bitten by that one many, many times!

Is it a laptop? It seems I’ve had issues with other devices (ATTiny, I think) on my MacBook Pro (summer 2012). It’s been a while, but I think those devices didn’t work on the USB port on the right, but worked on the left (or vice-versa). If that doesn’t work, see if you can try it through a USB hub.

Hmmm. But I can communicate with my NodeUSB units just fine over USB serial… So it’s not completely a generic USB3/El Capitan problem.

1 Like

Well, I thought I had things working, but I’m still having issues. I have gotten to the point where particle serial identify will give me my Core ID. But particle serial wifi or particle flash tinker won’t work. And I can’t get it to talk to my Photon.

BUT, I was able to configure WiFi on my Core using a regular terminal program (CoolTerm). To do this, I put my Core in Listening mode (blinking blue), configured CoolTerm for the ‘usbmodem1411’ (might be different for you?) device, a baudrate of 115200, and connected.

Then I hit ‘w’, and it prompted me for my SSID, security type, and password.

So at least I’ve got my Core back online.

EDIT: My Photon comm problem turned out to be a cable issue. So I was able to communicate with both my Core and my Photon with a standard terminal program, but my success with particle serial is only partial.

1 Like