[Update 1/21] Intermittent SIM management issues

electron
boron
Tags: #<Tag:0x00007f038fbdbc50> #<Tag:0x00007f038fbdb9a8>

#1

Update 1/21 - For users experiencing a large number of activation failures, please check out this follow up response here here

Hey, all.

One of our telephony partners is having intermittent issues with their SIM management APIs. It’s been going on a couple of days, but it ebbs and flows in frequency. It hasn’t gotten bad enough to warrant a status page incident, but we wanted to keep you all up to date.

If you have a 2G/3G Electron or E Series and you try to activate, or deactivate your SIM, it might not happen immediately. If you get an error, go ahead and wait a few minutes and try again. Failures are pretty rare overall, but still happen and the best thing to do is just try again after a few minutes.

LTE E Series, and Borons aren’t affected.

To be clear, this isn’t a problem with your device, or our APIs, but with our partner’s API. It makes it difficult to provide estimates on when they’ll have it fixed. We’re working closely with them to resolve the issue. We know it’s frustrating.

Feel free to post here if you have any general questions. If you want to discuss something with our awesome support team, you can send us a message from the support page.

Thanks!

JT


#2

Thanks JT for the post! Very much appreciated and thank you for the updates!

For everyone who is experiencing issues. As this is an issue with our telephony partner, unfortunately the ability to provide support at this time is limited. We will try to use this topic as our source of truth as we continue to investigate this issue.

Should you have any other questions or concerns, or believe you may be experiencing something outside of this issue (even if you are uncertain)! Please feel free to reach out to us here on this community post or the provided support page by JT.

Thanks everyone!


#3

#4

I am trying still, but it isn’t successful. If the problem is only with electron can I activate the sim using a boron and use it after with electron?


#5

I’ve been in discussion with a member of Particle Tech Support who pointed me to this thread. The issue with activating my SIM card is certainly is not “intermittent” for me here in the UK. I’ve tried it at least five times in the past week, with my Electron powered up and plugged in. It’s brand new out of the box and I haven’t modified it in any way.

I ordered the Electron in December from Farnell as the Boron was not in stock at that point. If the issue with the SIM activation persists, and the Boron is indeed not affected, I may have to look into exchanging my Electron board.


#6

Hi! I got my first Particle board, the Electron. I tried to activate the SIM on 17Jan2019 around 21:00PST. When I press the “Enroll & Activate SIM”, I get “Error Our back-end service could not process your request.” After a few hours of reading, retrying with different browsers/computer/networks, and getting the same result, I wrote to support and ordered a Boron. I’ve tried to activate the SIM at 11:00PST and 13:00PST today, 19Jan2019. I still get the same error. I’m hoping that the error has become 100% repeatable so that it will become easier to fix. Has anyone been able to activate an Electron SIM since 17Jan2019? Thanks!


#7

Made more attempts to activate the SIM today at 14:20, 15:20, 17:30, 19:00, 20:00, 20:20, 20:30 PST. Always get the same error as before. This seems 100% broken, 100% of the time. Anybody else able to activate?
Thanks


#8

Hey ESharp,

We have noticed an increase in downtime with this particular. Unfortunately, it is difficult for us to reliably track when this or is not up, as this is an issue with our telephony partner and nothing within our own system.

While we would very much like to unblock our customers on this issue, we are limited in our capacity to address it is the issue lies on our vendor’s system.

Please rest assured we are working with our vendor, doing all that we can to resolve this as quickly as possible.


#9

Hello David,

I do a apologize for the frustration.

Technically speaking, the issue is not necessarily with the Electron itself, but simply, the SIM card provided with it.The SIM card is one that is managed by our telephony partner. At this time, we recognize that their API is having significant downtimes, making it not possible to activate SIM cards at this time.

Rest assured, the issue is not with the SIM card or the Electron.

If you have a third party SIM card available, it should be possible to make use of a third party SIM to get your Electron up and running while we await for a resolution with our MVNO partner.


#10

Many thanks for your reply.

I have considered using a third party SIM for my initial testing. However, as far as I understand, this would preclude me from having access to the cloud service. If there was a possibility for me to be granted access to the cloud service while using my third party SIM, that would be perfect. Since my Particle SIM hasn’t been activated yet I have the three months of free access.


#11

Nope, it doesn’t.
As many threads show you can use the cloud with 3rd party SIMs, but you need to tell your device to use some alternative APN credentials and will have considerably shorter keep alive periodes to keep the connection alive (default 23 minutes - commonly 60-300sec).


#12

mstanley,

FWIW, having the same issue with an E-Series LTE. Flashed firmware update and then tried to register. No dice.

Regular updates would be appreciated, given that this is a blocking issue.

Cheers,
L3


#13

When does the three months of free access begin if you haven’t activated the Particle SIM?

I’ve spent five hours getting the CLI working on my Mac and flashing a blinky project. My university project involves reading BMS data via an SMBus interface, I’m keen to get this data broadcasting to the cloud as soon as possible.


#14

Cloud access is free for the first 100 devices (apart from Mesh setups, which is a different topic).
The 3 months of free data only start after you’ve activated the SIM, and are bound to that SIM, not the device/cloud.

With a 3rd party SIM card, you should be good to go, and still have full cloud access. You’ll need to include some specifics in your code as mentioned by @ScruffR above, but other than that, you should be fine.


#15

Oh that’s fantastic, thank you for the clarification. On the pricing page that isn’t clear at all. I had assumed the “first 100 devices” was only applicable to wi-fi devices and not cellular.

I have several GiffGaff sims with bonus credit, hopefully I will be able to make use of them with pay as you go.


#16

Hey there Leo,

Just to clarify, you are explicitly getting the error message about our backend service being unable to process the request?

We are investigating issues with the E Series LTE as well–but they should be different. The LTE E series do not make use of the same MVNO as our Electron/E Series 2G/3G global–so they should be unaffected by this particular issue.

Could you describe to me the issue you are having with your E Series LTE?


#17

Hey David!

It looks like @ScruffR and @Moors7 were able to clarify this for you. But just to re-iterate–you can still use the device cloud with a third party SIM! The language isn’t exactly clear–but yes, access to the cloud is free for the first 100 devices.

For cellular, our pricing models are specific to the SIM and data connectivity. If you provide your own SIM, these costs don’t apply as we’re not managing your cellular connectivity overhead.

Your three months free are for the SIM’s overhead management fee. This begins from the moment you activate the SIM, specifically. So once this issue is resolved and you activate your SIM, the clock starts ticking then.


#18

Just to clarify on this for others, the $2.99 fee is for SIM management specifically. It is applied regardless of whether data is used or not. If the SIM is active, this is charged as there is overhead to keep it active with the MVNO.

This $2.99 is waived in the first 3 months after activation, making it free.

Every single month (including the first 3), the first 3 MB of data are free–as in, we do not charge per MB for these first 3 in any case. After 3 MB, we do charge for additional MBs. This holds true in the first 3 months as well. So if you use 5 MB in the first month after activation, you are still responsible for the 2 MB over even though we waived the $2.99


#19

mstanley,

Yep, that is the message:

Our back-end service could not process your request. If this message persists, please contact support.

It didn’t work last night or this morning or just now…

Cheers,
L3


#20

That’s certainly concerning. Could you open up a support ticket or private message me here and provide me with the device ID and ICCID? I’d like to investigate this further.

Thanks!


Cannot register Electron; 'backend failure'