Tutorial: Installing DFU-Driver on Windows [24 Feb 2015]

@OrangeOctober,

seems like everything installed correctly but Spark-cli didn’t seem to like it :stuck_out_tongue:

Can you try this just to be sure: dfu-util -a 0 -s 0x08005000:leave -D firmware.bin

I have a feeling that DFU-util is not in the PATH for your command prompt so when Spark-cli called for it, it’s not recognised.

Hi There;
I’ve just installed Windows 8.1 Enterprise 64 bits on my laptop, really a fresh install today, just installed Office 2013 then gone trough Windows Update, that’s all.
Then plugged my core with no effect and not seen in device manager. I put the core in smart config and same thing, not seen in device manager, So my last test was to put the core in DFU (blinking yellow) and launched Zadig 2.1.1 as administrator, no luck again, the listbox does not show me the USB Device CORE DFU (of course I checked list all devices) . I’m really stuck because did not had any problem on my Windows 7 64 bits.

Any idea, because I really don’t understand ?

Thanks for your help.

Answering to myself, problem solved, I’ve got a wrong USB cable, so make sense, with original Spark USB cable, everything is working file,

For some reason, on windows 10, even when not requiring signed drivers, the spark_core.inf driver was totally not working (exclamation point). So, I found this thread and followed it and it worked.

1 Like

@kennethlimcp. The cores we have been using got into a continuously-blinking-green mode. This tutorial has been immensely useful in getting the cores back to working mode.

My suggestion is to make this part of the standard documentation or FAQ so that it serves as a quick reference for anyone who comes across this problem. It will be nice to have a separate Troubleshooting section in the documentation part. Several such problems and solutions can be collectively presented in this. This can be very useful

Thanks

1 Like

Added this recently - [Spark core] Common issues

@kennethlimcp Hi, I’m quite new to the community and have been trying to fix issues with the core for about 3 days now (it happens to be much harder than it seems!). I’ve gotten to dfu-util and have downloaded the file you’ve given, but I don’t know what I need to put into the path. I’ve put “C:\Program Files (x86)\dfu-util-0.8.tar.gz” into my path (yes, I did add the semicolon beforehand), but cmd still doesn’t recognize dfu-util. Is there anything that I’m doing wrong here? Please ask me if you need any other information. Thanks :v:

It’s not that hard. :wink:

You will need to extract the dfu-util.exe to use it :wink:

1 Like

Hi, for some reason I still can’t get it to work. I’ve extracted the file and copied the path to that where “dfu-util.exe” is, yet the computer still does not recognize the command. Here is my path: C:\Users\Andrew\Downloads\dfu-util-0.8-binaries.tar.xz\dfu-util-0.8-binaries.tar\dfu-util-0.8-binaries\win32-mingw32.

@Werdna, I suggest you move the win32-mingw32 directory to the root of the drive and use that path instead.

2 Likes

Wow. That worked like a miracle!

2 Likes

@kennethlimcp, How do I update my current rev 0.7 DFU to 0.8? I downloaded the “dfu-util-0.8-binaries.tar.xz” binary but I’m not sure where or what I’m suppose to do with this file to update the DFU.

Any help will be much appreciated.

@wesner0019, the file is actually an archive (like zip) file. What OS are you running on?

@peekay123, windows 7

@wesner0019, if you have winzip or 7zip or winrar, you should be able to right-click on the file and open it as an archive. If so, open the .tar file which is also an archive. Once open, open the directory you will see (dfu-util-0.8-binaries) and you will see the win32-mingw32 directory. The contents of that directory need to replace the ones in the directory on your PC.

@peekay123, got it, working now, thanks!

1 Like

I tried for hours to get this to work on my windows7 machine. The dfu-util would never see the core. I finally read on another post that the dfu-util doesn’t like usb3 ports. I switched to a usb2 port and volia it works.

If dfu-util doesn’t see it, change it to a usb2 Port (usb3 didn’t work for me)

4 Likes

what do you mean exactly mean by

I did all the above but I can’t find dfu-util.exe and when I write dfu-util in cmd I get:
‘dfu-util’ is not recognized as an internal or external command…
What is the problem?

@mohmhus, Windows has an application search path. Open a CMD prompt and type “path” and you will see what your present windows search path is. For dfu-util to run from any directory, windows needs to find it. It does this by looking in the search path. You need to add the directory where you put the dfu-util.exe (and supporting files) to the path.

You can find help on doing that here or by googling “windows add to path” for example.

2 Likes

If you look at the end of the tutorial, i have already provided a link on how to do that :wink: