Tutorial: Installing DFU-Driver on Windows [24 Feb 2015]


#21

Glad it helped! I have no control on what content goes on the official repo since Spark did not write this tutorial so I’ll leave it as it is :slight_smile:


#22

Hi I can’t find the CORE DFU driver in the Zadig when I select list all devices I have already installed the Spark CLI tool but can’t install the DFU tool. I am using Windows 8.1
Thanks
Meth


#23

Ken, thanks for this information. It worked for me. Especially checking the driver. I had a Yellow exclamation sign at the driver and deleted it. But then I came in a kind of twillight zone or chicken egg problem. I put the Spark in DFU mode and started Zadig. There I saw in the first place a combination driver for Spark and Arduino but not the driver you mentioned in this topic. I got also the message from Windows that it could not find the DFU Driver, I had deleted it. So I did a warm boot of Windows. Spark was still in DFU mode. After starting Zadig I saw the CORE DFU driver.

The big problem I had is who or which program delivers what? Who is delivering the CORE DFU. Who is delevering a Windows binary of the dfu-util.exe. Yes in the end I found it but I had problems with putting the steps and download places in the right order. I know this is not your fault, just my experience getting my Spark online. :smile:

Nevertheless your information helped me getting the driver back.

------------- edited some typos --------------


#24

I followed these instructions and am having problems flashing using dfu-util. I had this working at some point in the past but something has evidently changed.

Running dfu-util says
dfu-util 0.8
Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Found DFU: [1d50:607f] ver=0200, devnum=13, cfg=1, intf=0, alt=1, name="@SPI Flash :SST25x/0x00000000/512*04Kg", serial="8D8C0F745153"
Found DFU: [1d50:607f] ver=0200, devnum=13, cfg=1, intf=0, alt=0, name="@Internal Flash  /0x08000000/20*001Ka,108*001Kg", serial="8D8C0F745153"

trying to flash spark flash --usb FIRMWARE gives

Apparently I didn't find a DFU device? util said
Error writing firmware... no dfu device found.

Device manager lists one COFE DFU device under “libusbK USB Devices” which is the CORE DFU

Thoughts?


#25

@OrangeOctober,

seems like everything installed correctly but Spark-cli didn’t seem to like it :stuck_out_tongue:

Can you try this just to be sure: dfu-util -a 0 -s 0x08005000:leave -D firmware.bin

I have a feeling that DFU-util is not in the PATH for your command prompt so when Spark-cli called for it, it’s not recognised.


#26

Hi There;
I’ve just installed Windows 8.1 Enterprise 64 bits on my laptop, really a fresh install today, just installed Office 2013 then gone trough Windows Update, that’s all.
Then plugged my core with no effect and not seen in device manager. I put the core in smart config and same thing, not seen in device manager, So my last test was to put the core in DFU (blinking yellow) and launched Zadig 2.1.1 as administrator, no luck again, the listbox does not show me the USB Device CORE DFU (of course I checked list all devices) . I’m really stuck because did not had any problem on my Windows 7 64 bits.

Any idea, because I really don’t understand ?

Thanks for your help.


#27

Answering to myself, problem solved, I’ve got a wrong USB cable, so make sense, with original Spark USB cable, everything is working file,


#28

For some reason, on windows 10, even when not requiring signed drivers, the spark_core.inf driver was totally not working (exclamation point). So, I found this thread and followed it and it worked.


#29

@kennethlimcp. The cores we have been using got into a continuously-blinking-green mode. This tutorial has been immensely useful in getting the cores back to working mode.

My suggestion is to make this part of the standard documentation or FAQ so that it serves as a quick reference for anyone who comes across this problem. It will be nice to have a separate Troubleshooting section in the documentation part. Several such problems and solutions can be collectively presented in this. This can be very useful

Thanks


#30

Added this recently - [Spark core] Common issues


#31

@kennethlimcp Hi, I’m quite new to the community and have been trying to fix issues with the core for about 3 days now (it happens to be much harder than it seems!). I’ve gotten to dfu-util and have downloaded the file you’ve given, but I don’t know what I need to put into the path. I’ve put “C:\Program Files (x86)\dfu-util-0.8.tar.gz” into my path (yes, I did add the semicolon beforehand), but cmd still doesn’t recognize dfu-util. Is there anything that I’m doing wrong here? Please ask me if you need any other information. Thanks :v:


#32

It’s not that hard. :wink:

You will need to extract the dfu-util.exe to use it :wink:


#33

Hi, for some reason I still can’t get it to work. I’ve extracted the file and copied the path to that where “dfu-util.exe” is, yet the computer still does not recognize the command. Here is my path: C:\Users\Andrew\Downloads\dfu-util-0.8-binaries.tar.xz\dfu-util-0.8-binaries.tar\dfu-util-0.8-binaries\win32-mingw32.


#34

@Werdna, I suggest you move the win32-mingw32 directory to the root of the drive and use that path instead.


#35

Wow. That worked like a miracle!


#36

@kennethlimcp, How do I update my current rev 0.7 DFU to 0.8? I downloaded the “dfu-util-0.8-binaries.tar.xz” binary but I’m not sure where or what I’m suppose to do with this file to update the DFU.

Any help will be much appreciated.


#37

@wesner0019, the file is actually an archive (like zip) file. What OS are you running on?


#38

@peekay123, windows 7


#39

@wesner0019, if you have winzip or 7zip or winrar, you should be able to right-click on the file and open it as an archive. If so, open the .tar file which is also an archive. Once open, open the directory you will see (dfu-util-0.8-binaries) and you will see the win32-mingw32 directory. The contents of that directory need to replace the ones in the directory on your PC.


#40

@peekay123, got it, working now, thanks!