Trouble getting Photon set up on WiFi

Strange behavior - my Photon would start up, but immediately go to SOS with 1 red blink with Tinker installed when I tried to set a digital input to Write. I updated the firmware to 1.2.1 without any benefit. So, I ran particle doctor but it failed every time indicating it did not successfully install the doctor app. I read where someone else was having an issue due to WiFi, so I erased the WiFi credentials (hold SETUP for 10 seconds until it flashes blue rapidly) and tried to add it again via the Particle app. It fails every time and results in breathing green. I also tried the CLI, but it fails, too. The Photon is running 1.2.1. As a side note, I believe I started having trouble with this Photon when I tried to install it at a site that had a WPA2 password 13 characters long with an ending exclamation point that may not be acceptable. Any thoughts would be greatly appreciated!

[update] BTW, after a power cycle, the Photon is breathing WHITE.

[update] Just did a particle flash --usb tinker and all is good. Seriously?

(I just repost your final edit to mark this thread as solved)