Cannot bring my photon online, could this be a hardware issue?

Hi everybody, this is my first post in the particle community forums so I apologize if I’m breaking some sort of etiquette!

In the Particle CLI, I have run the setup, successfully connected the device to wifi, and named the device. But as soon as the particle setup wizard is complete, $particle list shows my photon to be offline. I cannot flash programs to the card via the online particle IDE or the Atom IDE even though the photon device appears in my devices list. I have run the doctor on the photon multiple times and tried to connect to two separate wifi networks.

Has anybody else had this bizarre issue?

Has a different program other than the default Tinker ever been flashed to the Photon? If so, have you tried using safe mode when attempting new program flashing? It’s possible that a custom program could be blocking the cloud connection, and therefore, also the online flashing functionality.

I believe the most recent program flashed to the photon was the default tinker. I am almost convinced that something must have gotten disconnected within the actual device and is impeding its ability to connect. Is this a common defect?

Hmmm… it’s always possible to have a hardware defect that would prevent cloud connection, but it’s uncommon.
Could you tell us what the RGB LED is doing when powered up?

Most important questions before jumping to the assumption of a HW defect

  • what is the RGB LED doing on your device?
  • what device OS version have you got on your device?
  • have you tried particle update (in DFU Mode with most recent CLI version 1.39.0)?
  • can you post the output of particle serial inspect (in Listening Mode)?

I am colorblind (which has made fiddling with the Photon about 5 times more difficult haha), but based on my best judgement and some cross examination online, I believe the led cycle that displays on power up is the slow cyan, fast cyan, 3 yellow/red/orange blinks, and then repeat. From what I’ve been able to find, this pattern indicates bad keys. I have attempted to repair my keys many times but for whatever reason the LED is stuck in this pattern and cannot reach pulsing white. Are there any full proof ways to repair my keys?

-The RGB LED is flashing slow cyan, fast cyan, and then three yellow/green/orange blinks (I am colorblind, hence the vagueness), and then repeat. Online, it says that this indicates bad keys.

-particle identify tells me that it is running OS 0.7.0

-Just tried, it said that it was up to date

  • “Platform: 0 - Core”

Huh?

You were talking about a Photon but particle identify tells you it’s a Core?
Can you post a photo of your device?