Breathing cyan but is offline


#1

I set up my photon using the particle app and everything goes well until the end when it looks like its connected since it is breathing cyan but I get an error message that reads:

Setup Completed
Your device has been successfully claimed to your account, however it is offline. If the device was already claimed before this setup then the Wi-Fi connection may have failed, and you should try setup again.

I’ve tried connecting through build.particle.io but it fails to connect. If I try to connect through the app then it shows offline on the app but online at build.particle.io but when I try flashing a program like blink it times out. I also can’t seem to star (select) the photon. It looks to me like it might not actually be connected. This is my first time playing with the device but so far it’s been a little frustrating. I’ve also tried connecting through particle CLI with no success (usually hangs up after trying to connect but never connects). Another interesting thing is I can signal to the photon and it will change colors.

Any help would be appreciated.

Thank you!


#2

Try Safe Mode.


#3

Hello,
Does anyone know if this was resolved? I have three Photons (one I gave to a friend) that are all experiencing almost exactly this same behavior. In my case, with two of the Photons, I did not get the “…however it is offline” error message. My friend did get that exact message.

We can both “signal” the Photons and they respond correctly. But we just can’t flash firmware. There is no purple flashing from the RGB LED.

Also, I have noticed that if I try flashing the example “Blink an LED”, it says it completed successfully. But there is not purple flash and the LED does not blink.

If I copy the example to my own code, I get a timed out error when trying to flash. It is also of note that if I try flashing the example with no Photons at all powered up, I still get a flash successful message from the IDE.

I will try to use Safe Mode when I get home tonight. I will also send my friend a link to this thread.

Thanks,
Joe


#4

Hi @jperch

It sounds like you might have a mismatch between the system firmware version on the device and the compiled against version of your user firmware. The system is set up to not let bad things happen with mismatched versions.

I would find out what version of system firmware you are running on these devices or upgrade to the latest version and try again from the web IDE.


#5

Hi Joe,

I ended up figuring it out on my own but I fixed this issue by upgrading the firmware. I had the same issue on a few boards and they all worked after.


#6

@bko and @fvera,

Thank you very much for your responses to this inquiry. In thinking about this a bit more, your responses make sense. Of the two Photons I currently have, one was obtained as part of a special when the Photons were first announced. If you bought a Core at a special price, it would be shipped right away. You would then get a Photon as soon as they were available. So this Photon has been sitting around for a while. The other one I have I bough from Spakrfun in March of 2016.

The third one that my friend has, I think I gave it to him over a year ago (maybe 2?). So it stands to reason that if outdated firmware could cause a problem, this would be a likely cause.

I will pass this on to my friend and I will also try this out tonight (hopefully).

Thanks again,
Joe

P.S.
fvera,
You might want to tag this thread as resolved (I assume you can do that) so that others can find this solution more easily.

Joe


#7

So, does anyone have a recommendation for how to update the firmware in these Photons? I downloaded the firmware manager. But all it does is either attempt to connect to the Photon forever (I have waited as much as 30 minutes) or it generates a -1 error.

I am starting to loose hope in these devices. I thought the cores were a PITA. But these Photons are giving them a run for the money.

Can anyone help?

Thanks,
Joe


#8

To update the particle by putting it in DFU mode (DEVICE FIRMWARE UPGRADE) and then connecting to it via usb through CLI software (if using windows) and you type the update command which i think was “particle update”

https://docs.particle.io/guide/getting-started/modes/photon/

To enter DFU Mode:
Hold down BOTH buttons
Release only the RESET button, while holding down the SETUP button.
Wait for the LED to start flashing yellow (it will flash magenta first)
Release the SETUP button


#9

https://docs.particle.io/reference/cli/#particle-update


#10

@fvera,

Thank you very much for this information. If you couldn’t tell from my latest post, I am getting a bit frustrated with these devices. When you said I needed to update my firmware, I thought this would not be too bad of a process. I looked at the support page and the first thing I came across was this firmware manager application. So that is the path I followed. Now it seems like that was not the right thing to do.

I appreciate your help. One thing to note is that my friend with the third Photon was able to figure out how to update his firmware and it did fix the issue. So I am confident this update will also fix my issues. I just need to figure out how to do it.

My friend did tell me how he did it. But he is using a MAC and I am using a PC. So I don’t think the steps are quite the same.

Anyhow, thanks again,
Joe


#11

Depends what his steps were. Generally the update works the same irrespective of OS.

I can understand your frustration about the “dead-end” firmware manager. We have been asking for an updated version that provides the most recent version, but Particle hasn’t been able to provide that yet.

But getting the most recent CLI and running particle update in DFU mode shouldn’t be too much of an issue and it also allows to try out release candidate versions (currently most recent 0.7.0-rc.4)


#12

@ScruffR,
I think the issues he had were related to making things work on a MAC before using the tools. Something about changing his shell to Bash, etc.

@fvera,
Your instructions were immensely helpful! THANK YOU. At first it did not work. I installed the software using the Windows installer that installs node.js, the dfu-utility and the particle-cli. Unfortunately, that did not quite work out well. The driver kept coming up asking if I wanted to install the driver software. I kept hitting install. But then it would just come back again. Eventually, I said no and it stopped.

Basically, when I would enter “particle update” it would just say it couldn’t find any Photons in DFU mode. Eventually, I figured out this was probably because the drivers weren’t installed correctly and the device manager wasn’t happy with the “photon in DFU mode” it found.

I also noticed that I had a really old version of node.js on my PC. At this point I just punted and uninstalled node.js, the particle CLI and everything I could find related to particle. Then I ran the Windows installer again.

This time the driver popup only came up two or three times and I committed to just hitting “install” every time no matter how many times it asked me.

This time everything seemed to install fine and the “particle update” command was able to see my Photon in DFU mode and try an update.

But, once again, there was an error. The error said something about an “invalid DFU suffix signature”. I remembered seeing something about this message somewhere on the forums and that it was a false error and it should be okay to ignore it.

I repeated the update with my second Photon and got the same error. But when I tried to access them using the mobile app, the Tinker link seemed to be working. I tried it and BANG! the Photon responded to me changing the D7 pin as it should!

The other Photon also responds to Tinker and I was able to flash both of them with the blink example from the IDE.

So I AM HAPPY!

I want to thank every one on these forums for all their help. Particularly fvera, bko and scruffR who responded to me so graciously.

Thank you all very much.

Joe


#13

I know I was a little frustrated as well when trying to set it up the first time especially something that is supposed to be the easy part. I’m glad it worked out!