Photon breathes cyan but is offline

I bought two photons recently. The first one is up and running great and I’ve been doing some neat beginner things with it (temp / humidity, etc.). I decided today to start a new project with the other one that I’m pretty sure worked for a little while (I did manage to “claim” it, after all), but I can’t say for sure since I didn’t really hook up any sensors or other stuff to it.

In any case, this Photon was now showing up as offline when I would power it up – but the light was “breathing cyan”. Occasionally after a power cycle the device would be visible “online” for a few seconds, but then it would be offline again. I tried safe mode, and just about everything else I’ve found in the forums… I even resorted to trying a factory reset when nothing else worked. I am able to connect to it over USB – kind of. The “Particle setup” command line process sees the device and gets as far as trying to tell it WiFi info before it just hangs – showing “obtaining device information” over and over. Connecting via Coolterm lets me set SSID and password… but the Photon never actually goes online.

I eventually managed to get the latest copy of df-util.exe (had to upgrade my older 7-Zip to open the dfu-util-0.8-binaries.tar.xz file) and I successfully (re) loaded 0.4.4 firmware binaries. But still the Photon “breathes cyan” and won’t connect. In fact, I don’t see it on the list of WiFi devices in windows ether, so it really feels like something with the WiFi is just “broken”.
If anyone has any suggestions of something else to try, please let me know!
Thanks,
Ted

Has it been claimed under your account yet?

I would try something like particle flash deviceName tinker and see if the device responds to the OTA update

1 Like

Thanks for the suggestion, but as I indicated – I was able to claim it when I first hooked it up.

After using dfu-util to reflash firmware didn’t do anything, I did unclaim it. It took me quite a while to re-claiming it because it wouldn’t stay online long enough. I eventually timed things just right and got it claimed under my account, but it still won’t stay online more than a few seconds – even though it still breathes cyan.

One other observation – my working Photon never gets warm, but the problematic one does (not hot, just noticeably warmer). Makes me wonder if that could be an indicator of a hardware issue? But if it were hardware, why would it continue to breathe cyan?

I would attempt to place it in Safe mode and see what happens with the status of the Photon

After more than a day of being unplugged, I plugged my problem Photon back in. Wow! It was working again!
And it continued to work for well over an hour. During that time I set up both Photons the same way – both are reading a DH11 sensor. And both were reporting the values which I was displaying on a web page. …Until a few minutes ago when the problem Photon decided to stop working again!! And when it it stopped working, I hadn’t done anything with it for 3-4 minutes, so I’m 100% sure that I didn’t do anything that could have contributed to its sudden failure. All that happened is that it simply disappeared off the network and is now shown as “Offline” Despite this, the device continues to breathe cyan.

Based on this, I think it’s pretty clear that I simply got one defective device (out of two). Hopefully I can return it for a new unit?

It doesn’t sound like the device is defective, but perhaps there is an issue in firmware or in the cloud that needs addressing.

I will be investigating the reports of flashing cyan forever and connectivity issues this sprint, so hopefully we’ll have some answers to these strange behaviors.

Hi @mdma
I’ll chime in here, too - experiencing same -
Photon breathing cyan but offline. Not “offline” but really offline! I powered down my wifi hotspot that serves both my core and photon upon seeing I was no longer getting published events from the photon for about 10 minutes. The core started flashing green immediately, the photon still breathing cyan and doesn’t reconnect after hotspot restarted until photon power-cycled.

Which firmware version is this?

I’ve had this happen a few time a few weeks ago, so it would be 0.4.4 and 0.4.5
Additional footnote - the hotspot has dropped connections a few times today but both core and photon reconnected after it recovered most times. I did have to restart the hotspot once earlier today, too. I don’t mind if it doesn’t like my hotspot… I don’t much like it either. :wink:

I’ve experienced this problem as well and reported it on another thread. My Photon mysteriously went “offline” even though it was breathing cyan. In addition, I can tell that it was running my code in loop() because my code double blinks the D7 LED when I take certain actions (trip wireless sensors). Resetting the device always got it back online. This “spontaneous” going offline happened once and I cannot reproduce it. A few days ago, I was able to cycle power and see the Photon come up running OK but still report as offline in the cloud. This would happen about 50% of the time that I cycled power on the Photon and I was always able to recover via a reset (either power cycling reset or the reset button).

I have been running my Photon for a few days now with no spontaneous going offline. I tried cycling power a few times just now and the device always resets properly and comes up online.

When I was having these problems, I noticed another problem – the system time was not initialized properly sometimes (it was a valid time but not the correct time). Again, any sort of reset got the device back online and also reporting correct system time.

I had upgraded to 0.4.5 firmware and this did not change these symptoms. What has changed, however, is that a few days later, these problems do not see to reappear. Since I haven’t flashed any firmware at all during this time, I think that there must have been some cloud communication issues. However, because I had not been able to determine how to reliably reproduce the problem(s), it is hard to say definitively that these problems has disappeared.

One more thing – my firmware was running fine on Cores for many months. None of these issues ever arose. They have arisen with the Photon - most likely as a result of the change to running the cloud connectivity in another thread via the RTOS (a new Photon innovation). Hopefully, these were simply cloud/RTOS stability issues that the Particle folks have resolved.

At present, the Photon is still single threaded, just like the Core. I believe these are timing issues, since the photon connects much faster than the Core did. cc @Dave

What can happen is that the application thread can block on something, which then causes the cloud connection to terminate. You mentioned the LED stopped blinking, so it could have been that. When the app is blocked, no cloud commands can be serviced. After 15 seconds or more of being blocked then the cloud connection is terminated by the :cloud: I’d like to add a status LED notification when this happens so the device indicates that it’s not online (e.g. flashing cyan would be good) so at least the local cloud connection status and the cloud connection status are in sync.

Going forward, we have multithreading lined up for the photon. This will ensure that an application that has blocked in it’s own code doesn’t stop cloud connectivity, and conversely, that cloud connectivity doesn’t block the application. We will be releasing a beta of this within a couple of weeks.

@mdma: thanks for the clarifications. Just for me to be clear, there was no change in LED behavior when my Photon would go offline. The system LED was breathing cyan. The D7 LED is under control of my application and double blinks when a registered wireless sensor is tripped. While the cloud was reporting my Photon to be offline, I could trip sensors and observe the D7 LED double blinking, as is normal during loop() in online operation. Thus, my application was confirmed to be running even though the Photon mysteriously went offline. My code was running but since the cloud believed the device was offline, I could not access my data.

Understood! Thanks for the detail there. We will continue researching this!

Hi Mat,
Update - still happening since re-upgrading to 0.4.5
It just did it a half hour ago after it threw a few high temp reads on my ds18b20.

Going to rollback to 0.4.4 and let it run for a day. I’ll keep you posted…

I believe changes were recently made cloud-side to improve this. Let’s bring in @Dave, who surely has more on that!

Firmware side, I just added a fix so that if the cloud isn’t talked to within 15 seconds, the system automatically displays this in the LED (goes back to breathing green). That will rule out a potential source of inconsistency - when the cloud truly does become disconnected but the device is stuck in a loop and unable to update the LED to reflect the connection status.

2 Likes

I just got a Photon device a couple days ago, and used my iPHONE to activate it yesterday. It seems to be breathing cyan, but it is listed as offline on my iPHONE and in my Dashboard. I have tried to install it about 4 times now, exact same results. Really just regurgitating what everyone else is saying, except that this is a problem out of the box.

1 Like

Have you tried resetting the device? That may help bring it online.

1 Like

I have reset it several times. I have reclaimed it several times. Granted, I have only been playing with this for 8 hours over 3 days. I did notice something interesting… When I go into the DashBoard, the device is listed as off line, but the Last scene time stamp is correct. Infant, I am able to disconnect the power for about 20 seconds, re power it, and the DashBoard timestamp will refresh with the correct time. So I am able to confirm that the device is claimed by my account ( several times ), It is listed in dashboard, but with a brown dot. The Mobile apps also list the devices as off line.
So, my amateur theory is that the problem is in the cloud. The device is reporting that it is attaching but that is the end of what it is doing. Perhaps the device really is in off line mode? but I would imaging that the device would start running the tinker firmware at this point.

Perhaps I should confirm some issues.
1… The photon, out of the box, once it is claimed, should default to the tinker firmware ( true or false ).
2… The Photon, out of the box, once it has been claimed, should report as online ( true false )?
3… The photon, after it is claimed, should be breathing cyan ( true False ).

I ordered 3 more devices just for giggles to see if I can get something to work.

Any suggestions on what to do next?

The only thing I can think of is that the Wireless network is passing through an apple AirExtreme network device, which is attached to a CABLE MODEM HUB, which has wireless turned off. My provider is comcast. I am thinking of turning the hub back on to see if that is the issue.

I have tried alternative power supplies but I do not think that is the issue.

I would also like to suggest that someone at tech support look at my device ID and see if they can spot something interesting. I would list it online but I am not sure if that is safe. perhaps someone in tech support can email me?

2 Likes

You can PM your device ID to me, and I’ll take a look!

Following our test-fleet of Photons through their boot-cycles on the Dashboard, I’ve noticed the following issue:

Occasionally, the device comes online (publishes Device Online), then immediately publishes Device Offline, but continues to “breath cyan”. It appears as offline on Build, and through the CLI command particle list, however, I can still flash the device and call functions/variables.

Investigating further, I noticed that if I hit the Cloud at /devices the device will be listed with {connected:false}, but if I check the Cloud at devices/ITS_DEVICE_ID it will tell me it is connected.

So it seems like whatever is keeping track of the Photons’ online/offline state is getting messed up because of a faulty Device Offline publish.

Another annoying bug, is that the response JSON from devices/ITS_DEVICE_ID only contains the field last_heard when the device is connected, which is annoying for obvious reasons… :stuck_out_tongue: