Particle Photon Flashing Cyan and Red. (or sometimes just Cyan) [SOLVED]

I’ve had a Particle Photon in operation running my garage door for about 6 months. A few days ago, I powered it down and made some minor wiring changes. Upon restoring power, I’ve gotten many different flashing light sequences, but can never get it to connect to the cloud. Added challenge is my colorblindness, so I keep having to get someone else to look at the blnky lights for me.

I’ve reverted my wiring change, in case that was the problem, but now I can’t get it to do anything. I’ve been Googling for HOURS and DAYS, and I’m pretty close to using a hammer as the final solution and abandoning this platform for life. (attempts to control frustrated rant)

Current state: I’ve installed CLI, worked thru several errors and bugs there. I’ve tried to repair the keys with “Particle keys doctor <Id#>”. I frequently get “no serial port” identified and hung terminal screens with the CLI.

The Photon is currently fast flashing cyan. (or sometimes Cyan and occasional Red/Orange)

I’ve tried so many things, I’ve lost track. I wish I had a “factory reset” button, but this seems unavailable.

Please help. Where to start from scratch?

Here’s my latest attempt, from this thread.

  • Place the device in Listening mode (blinking blue)
  • particle serial identify (to get the device ID)
  • Place the device in DFU mode (blinking yellow)
  • particle keys doctor PASTE_DEVICE_ID_HERE
  • hit the Reset button and the Photon should connect properly

I did the above, but the result is that the photo reverts to the fast blinking cyan & occasional orange/red.

Any advice would be appreciated.

EDIT: about to try adding “particle keys server” as a final CLI command.

I had a Photon acting up on me the other day where it wouldn’t accept a new sketch and here is what fixed it for me.

Using the latest version of the Particle CLI run this command:

Particle Doctor

Then follow the steps, you will need to put the device into blinking yellow DFU mode a couple times.

For me, the OpenSSL tool will not run at the end but it still fixed my Photon.

You most likely need:

particle keys server

as well. The particle doctor does that, as well, so that’s another option.

The full instructions for future reference are:

It is possible that you have corrupted device keys. You’ll need to have the Particle Command Line Interface (CLI) installed, so if you have not installed it yet, follow the instructions here:

if you are using Windows, make sure you use the Windows CLI Installer link and skip the other steps.

Put the Photon into Listening mode (blinking blue) by holding down SETUP until it blinks blue. Then issue the CLI command:

particle identify

Save the Device ID; you’ll need it later.

Then put the Photon in DFU mode by holding down both the RESET and SETUP buttons, releasing RESET and continuing to hold down SETUP until it blinks yellow and issue the commands below, in order.

particle keys server
particle keys doctor YOUR_DEVICE_ID

If you get this error under Windows:

'openssl' is not recognized as an internal or external command, operable program or batch file.

and you have used the CLI installer as described above, it may work if you do:

cd c:\OpenSSL-Win32\bin
particle keys doctor YOUR_DEVICE_ID

There are additional tips for a missing openssl error on this page, including tips for Mac OS X and Linux.

1 Like

Adding “Particle Keys Server” was the solution! Thanks very much!

Here’s the total solution that worked for me:

  1. Install Particle CLI on my computer (command line interface) link
  2. Connect the Photon to my computer via USB
  3. Open a “command prompt” window on my windows computer. (type “command prompt” into the start menu search box)
  4. Navigate to the directory C:\OpenSSL-Win32\bin> (by typing “cd C:\OpenSSL-Win32\bin”)
  5. Place the Photon device in Listening mode (blinking blue) (by pressing the setup button for 3 seconds)
  6. Enter “particle serial identify” into the command prompt window (to get the device ID)
  7. Place the device in DFU mode (blinking yellow)
    (Hold down BOTH buttons; Release only the RESET button, while holding down the SETUP button;
    Wait for the LED to start flashing yellow (it will flash magenta first);Release the SETUP button)
  8. Enter “particle keys doctor <DEVICE_ID>”. (replace <DEVICE_ID> with the ID from step 6.)
  9. Enter “particle keys server” into the command prompt window.
  10. hit the Reset button and the Photon should connect properly

That fixed it for me. Thanks for saving my Photon!