(re-open) fast blinking cyan mixed with 3 orange blinks

I’m having the exact same problem as described in this post (which was closed a while ago):

   https://community.particle.io/t/photon-flashing-cyan-and-blinking-orange/21530/26

Sorry to re-open this, but, well, I’ve made two Photons unusable now, and the apparent solution there hasn’t worked for me.

The solution in the above thread was to use the command

  particle keys server

but when I do I get this error message:

  Please specify a server key in DER format.

(BTW, I’m on WIndows 7.) So I tried using the “der” file produced by “particle keys doctor” (_new.der); same problem. I then tried using the “der” file produced by a “particle keys new”; same problem.

I can’t get the Photon into safe mode: it starts blinking magenta but then goes to fast blinking green and then to fast blinking cyan.

I can’t flash new code to the Photon. (This is what’s pretty serious … otherwise I’d be trying a bunch of code changes to see whether it’s in the code and if so, exactly what.)

In listening mode Ive done a “particle setup wifi”, but that didn’t change anything.

I’ve run the “photonfash.cmd” file with 0.6.1. It says it succeeded, but that didn’t fix the problem.

I’ve tried this at 2 different locations and so on 2 different networks.

Any ideas? Is there an order dependency that I’m missing? Some command I’m misusing?

Thanks in advance for any hints.

-Randy

(This is getting kinda’ long so I’m adding the following points on the application as sort of a footnote. Application code is usually very relevant, but in this case I don’t see quite how.)

I’ve got one moderately substantial application running successfully on several Photons. The app I’m working on now, which is where the problem started, is much smaller, but the code is derived from the larger one, so I’m not doing anything that I didn’t before. It (the new smaller app) was working fine in AUTOMATIC mode, and since I plan to run in MANUAL mode, I changed the source to that for some more realistic testing. It was running fine for a while. The Photon needs to be connected to the cloud to re-flash it, of course, so I invoked a bit of code I wrote to do a “Particle.connect()”. (This code came directly from the larger app, where it has worked fine.) That’s when the misbehavior began. It said it connected, but didn’t (re-flashing from the web IDE timed out). So I tried to get it into safe mode, but instead it went into the fast blinking cyan. I tried all the above things to no avail.

In the source code, I changed the MANUAL mode line back to AUTOMATIC and flashed this code to the second Photon. It seemed to go through a more “stuff” – maybe the firmware was being upgraded from 0.4.9 to 0.6.1? – and when that was done the fast-blinking cyan problem started. And I’m stuck.

If you are asked for a file with particle keys server you probably have an old version of particle-cli.

particle --version

The current version is 1.20.1.

The server key is different than the one from particle keys new. That’s a device key. The filename extensions are they same because they’re the same type of file, just for the opposite sides.

1 Like

Thanks @rickkas7 for the quick reply. Indeed, I had 1.18 (uh … dot 7?)
So I did the “npm install -g particle-cli” to upgrade and:

 C:\Users\Randy>particle --version
 1.20.1
 C:\Users\Randy>

So far, so good. But then, the next command:

 C:\Users\Randy>particle identify
 Error loading command C:\Users\Randy\AppData\Roaming\npm\node_modules\particle-c
 li\commands\KeyCommands.js SyntaxError: C:\Users\Randy\AppData\Roaming\npm\node_
 modules\particle-cli\commands\KeyCommands.js:213
         keyAlgorithmForProtocol(protocol) {
                                ^
 Unexpected token (
 Error loading command C:\Users\Randy\AppData\Roaming\npm\node_modules\particle-c
 li\commands\SerialCommand.js SyntaxError: C:\Users\Randy\AppData\Roaming\npm\nod
 e_modules\particle-cli\commands\SerialCommand.js:590
                     function parameterMissing(param) {
                     ^^^^^^^^
 In strict mode code, functions can only be declared at top level or immediately
 within another function.
 particle: Unknown command: "identify"

 C:\Users\Randy>

This is clearly something else (from the fast blinking cyan) and I probably neglected some step somewhere, but I’m hoping that someone might have a quick answer. I’ve been fighting the cyan problem for 3 days now.

What I would do is uninstall the CLI:

npm uninstall -g particle-cli

Then reinstall using the Windows CLI installer. That will also make sure your dfu-util and openssl installations are good, which you’ll be needing to have the particle keys doctor command work properly.

2 Likes

I did the uninstall and re-install using this link. All the particle commands are working fine now. Yay! Thanks!

So we’re back to the fast blinking cyan problem, which unfortunately is still present. At this point, I’ve tried so many different combinations of DFU mode, listening mode, particle keys doctor , particle keys server, …, that I may well be overlooking something obvious. So to reset here:

We think that fast blinking cyan indicates something is wrong with the keys. Do we know that for sure? Is there something documented somewhere that explains what’s supposed to be where and which commands put something there?

I followed the steps in this forum thread:

 https://community.particle.io/t/solved-photon-fast-blinking-cyan-with-a-random-red-burst/14359/6

     SOLVED....

      Here is what I had to do..


      1.) Put the Photon in DFU mode (blinking yellow).
      2.)  particle keys save mykey
      3.) particle keys send DEVICE_ID mykey.pub.pem
      4.) reset the device (unplug from USB and plug back in)
      5.) Perform setup CMD: particle setup

      SUCCESS!!!!

  This didn't quite do the trick until I followed up with this.

  https://community.particle.io/t/photon-setup-flashing-cyan-with-a-quick-red-burst-now-orange-burst-solved/12118/21

  Download the server keys from:

       https://s3.amazonaws.com/spark-website/cloud_public.der

  Then:

       dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der

So I did all this and it all seemed to work fine. But the Photon is still starts blinking fast green and then switches to blinking fast cyan.

(And it still doesn’t go into SAFE mode: it’ll start blinking magenta but as soon as I let up on the reset button it goes to fast blinking green.)

I guess you let go of SETUP when you see magenta, right?
The fast blinking green after that is normal, since the lead-up to magenta breathig is just the same as a normal lead-up to breathing cyan. So you may in fact already be in Safe Mode, but Safe Mode never makes it to the final stage (breathing magenta) due to the same reason as you can’t get into breathing cyan state.

Fast blinking cyan is a normal state during connection which indicates the cloud handshake.

We do know for sure and we have this documented here
https://docs.particle.io/guide/getting-started/modes/photon/

Can you post a video of the actual RGB signals?
“3 orange blinks” may not necessarily indicate a keys issue (depends on the speed of the blinks).
It could also have to do with your internet connection, firewall or previously set connection on the device.
Did you by any chance have a static IP set on your Photon?
If so, you need to explicitly reenable dynamic IP request.

1 Like

Static?! Yes, and that seems to be the key.
I found this thread by googling for “static”:

  https://community.particle.io/t/photon-is-unable-to-connect-to-wifi-after-flashing-static-ip-code-solved/23060/10

and I followed the instructions there and now have one of my Photons back. Thank-you! (I assume this’ll work fine with the other Photon I broke.)

But how did you think to ask about static mode? Is there a problem with using static mode? I’ve been using that in another application without problems. Has something changed in the firmware? Is there a combination of things I’m doing (or maybe not doing – reviewing my code just now I see a potential logic flaw in my call to “Particle.process()” (yes, I’m using MANUAL mode))?

Anyway, many thanks!


(Just to answer the other questions you asked …)

I guess you let go of SETUP when you see magenta, right?
Yes, right. I meant “SETUP”.

What I referring to when I asked “Do we know that for sure?” is whether that indicates something’s wrong with the keys. I had read the doc about the various LED blinking colors. The issue is (was) that it fast-blinks cyan “forever” … with the occasional orange (3 slower blinks).

There is no problem with static IP as such, you may just run into problems with your WiFi router if that IP wasn’t resereved or placed outside the DHCP range.
In that case the IP might not be available due to some other device already having claimed it.

Hmm … I’ll have to think about this.

But! Problem solved. (Both Photons are back in business … and I learned more new Photon things than I had imagined there were.) Many, many thanks.

3 Likes

I have a photon that randomly loses it’s keys. If I do a particle keys server. It will start to function again. After some time it goes back to the original failure. Fast blinking cyan with three orange blinks.

Is there a permanent fix?

@Bspranger, is the Photon operating with a battery?

Have you tried 0.7.x? It should have measures in place to prevent this.

no

I have not. I wasn’t sure how stable it was.

@Bspranger, loss of keys that often is most likely related to an under voltage condition on the Photon. Have you looked at the quality of your power?

I have not but I will. I am using a 12 volt supply with a 5 volt regulator to power the photon.

this is the device I am using:

@Bspranger, is the Photon always on or does it sleep? There are no specs for the product, including ripple and efficiency. Have you considered a higher quality unit from Pololu for example?

The photon is always powered up. It is controlling a Heat Recovery Ventilator which will integrate with smartthings to work with my furnace and the outside air quality (airnow.gov).

the fans are on the right side controlled by the photon. On the left side I have some model airplane props with a magnet and hall effect to measure the air flow. I have some calculations so I can control the fans to a specific CFM.