Photon suddenly stuck in Listening Mode after power failure


#1

My Particle Photon suddenly went into listening mode (flashing dark blue fast) after a power failure, can’t seem to get it out of listening mode, what am I supposed to do here? Do I use the Particle app to add a new device and delete the old one?

I have tried running it in safe mode, but immediately after flashing magenta it goes back into flashing blue listening mode.

I have tried running the Android app to reset the Photon’s wifi credentials, which I did, but now it flashes cyan+red. 3 cyan flashes, 1 red flash. Putting it in safe mode doesn’t fix that either.

EDIT: Fixed it by A) using the app to reset the wifi credentials, and then B) following this guy’s guide once it got stuck in flashing cyan/cyan/cyan/red mode:

This has happened to me before. Apparently these things really don’t like power transients, even though this is being powered through a well filtered USB power supply AND a surge protector. Their wifi credentials AND keys get corrupted, and you have to use those command lines to fix it. But once you do, it goes back to the way it was before, no need to reflash your firmware.