Can't Get Previously Running Photon to Connect

I have a photon that has worked fine in the past, and now blinks cyan with intermittent red bursts (I have no idea how it got into this state). I’ve tried everything I could find in other threads, but nothing works. I just ran keys doctor, and it looks like it gets to the end with this message,

attempting to add a new public key for device 36003d000547343232363230
submitting public key succeeded!
Okay! New keys in place, your device should restart.

However, it’s still blinking cyan with he occasional red burst. The device shows up in particle list as offline.

That patterns sounds like it is unable to communicate with the :cloud:.

What happens if you place it in Safe mode. :wink:

I can’t place it into safe mode. After blinking magenta for a few seconds it goes back to blinking cyan with red bursts.

Weird… Can you place it in DFU mode and do:

  • particle flash --usb tinker
  • particle update

Yeah, I did that before, and just tried it again. It gives me this message,

Your device is ready for a system update.
This process should take about 30 seconds. Here goes!

! System firmware update successfully completed!

Your device should now restart automatically.
You may need to re-flash your application to the device.

Still blinking cyan with occasional red burst.

Hm that is weird. Can you PM me your device ID? I can take a look at what’s going on in the Cloud logs.

1 Like

Any more thoughts on this? Is there a way to get the Photon back to the “fresh out of the box” state?

The following would have been the recommended steps:

  • particle update
  • particle flash --usb tinker

but you have done it already without any effect. To load back the factory image, a JTAG programmer is required.

Do you have another Photon? @mdma has done some cool stuff that might be able to solve your issue using another Photon to program the faulty Photon.

@kennethlimcp I do have another Photon. Do you have a link to this “cool” stuff?

If I build and flash locally, a program that puts the device in SEMI_AUTOMATIC mode, the software runs correctly, and I see output on serial. The problem does seem to be with connecting to the cloud. I think I’ve tried all the keys stuff a couple of times, but I don’t know if I did that correctly.

OK, It looks like I got it fixed. I’m not sure exactly what command did it; I think it was running “particle keys server” that was the magic step. After that, I was able to put the device in safe mode, and refresh firmware from the web IDE.

1 Like

Hey @Ric glad to hear it–feel free to ping me again if it doesn’t seem like the fix sticks.

Hi,

I have the same problem as Rick. I am struggling with if for two week but no result. My photon flashing rapidly cyan for 15-20 seconds and then flashing rapidly green and so on. Nothing helped: firmware update, WiFi reset, flashing tinker app, particle keys doctor, particle keys server, etc.
I have another two photons which just arrived yesterday and they are working well.