HELP! A series of cyan blinks and three red blinks? [Solved]

Dear all,

I have another device - a Photon mounting on its power shield. I was working fine, but it stops work five days ago after running out of battery.

I tried update the latest firmware and it starts to blink like this: a series of cyan blinks and three red blinks.

Please help me!

Thanks.

Could you take it out, place it in DFU mode and do particle update and then DFU again with particle flash --usb tinker?

I did. It starts with the SOS blinks few times and then a series of cyan blinks/three red blinks.

Any ideas? Thanks again.

Did you try this part?

Yes. I did.

Hmm, this might be a keys issue. Could you give the following a shot?
https://docs.particle.io/support/troubleshooting/key-management/photon/#how-to-change-your-key-

I got the pem file generated. Can you please let me know which email address should I sent the file to?

It might not be necessary if it connect already. If not, @Dave might be able to chime in.

No. It is in the connecting mode. Once I tried the particle setup, it starts to blink cyan and red (same situation)…

Hi @changks,

Once you’ve updated your keys with the particle keys doctor, you might also want to reset your server key as well. You’ll want to update your copy of the CLI as well:

npm update -g particle-cli

Then put your device into DFU mode again, and run:

particle keys server 

Once you’ve added the new keys, you should also consider resetting to safe mode, or running tinker to make sure your firmware isn’t causing an SOS on connect (like @Moors7 mentioned).

Once you’ve done all that, could you post a video of your device behavior on connect, and / or PM me your device id?

Thanks,
David

2 Likes

Thank you so much. It’s now up in the air. May I ask one question - what may cause this issue? Did I do something wrong? I would like to know and try to prevent the issue may occur next time.

I also have one Core backed from Kickstarter long long time ago and I would like to get it running.

I’ve tried above mentioned instructions for this Core. It keeps blinking cyan followed with green. Any tips to solve this for Core?

1 Like

Hi @changks,

You might need to run the cc3000 update on the core, put it into dfu mode, and run:

particle flash --usb cc3000 

I think there is a bug in the current system firmware that sometimes causes some of the data stored in the DCT to become corrupted. Lets ping @BDub for more info.

Thanks!
David

2 Likes

It is a cc3000 Core. Now, I can see it is online from tying “particle list.” However, it blinks couple times in cyan and then it stays in magenta (no blinking!!). Anything wrong here…? Thanks again to put this old Core alive.

@changks, after doing particle flash --usb cc3000, you should put the device into DFU mode and do particle flash --usb tinker. The magenta is safe mode, waiting for user code.

3 Likes

Oops, sorry about that, it’s been a while since I updated a core. :slight_smile:

2 Likes

Thank you all. Now all devices are online.

3 Likes

@Dave @peekay123 @Moors7 since it looks like a public server key issue, I would have liked to see a backup of the flash before running particle keys server. Here’s what I have stated in the past:


It looks like you have no Public Server Key… would you please backup your Photon image first and send it to me at You just need to put the device in DFU mode and run this command (note the backup_replace_with_device_id part of the filename):

dfu-util -d 2b04:d006 -a 0 -s 0x8000000:0x100000 -U PHOTON_backup_replace_with_device_id.bin

In your email, please link to this thread so I have a history of things :smile:

Then with your device in DFU mode you can run this command to restore your server key:

particle keys server

Thanks!


In this case, there is no need to do that now @changks but if it happens again, please do :smile:

4 Likes

I found two backup image files. I’ve sent them to you. Thanks guys. :yum:

1 Like