SOS 13 Blinks After Flashing Tinker


#1

Hi all,
I’ve been having some weird SOS errors with my Photon so I decided to try and flash Tinker and update it. After that sequence however, it goes into the SOS 13 blink error. I don’t have any wifi credentials saved on it, and it goes into the 13 blink sequence after a few seconds of green blinking. I tried doing a manual firmware update (to 0.7.0) which loaded fine but still gives me the SOS 13 blink error. The only mode I can put the Photon into is DFU mode, and I can’t seem to figure out what to do from there.
If anybody has some advice for what to do next, that would be greatly appreciated!
Thanks


#2

What version CLI are you using?
Have you removed all external circuitry from the device?
What happens when you try to engage Safe Mode?

What you can try is to get the most recent CLI (currently 1.33.0) and run this in DFU Mode

particle flash --usb tinker
particle update
particle flash --usb tinker

Then you can try to put your device into Listening Mode (which should be automatic when you really have no credentials stored) and flash the bootloader via

particel flash --serial bootloader-0.7.0-photon.bin

#3

@ScruffR I was having this problem last night at a lab where I hadn’t connected the Photon to the wifi network. This morning back at home I powered it up without having touched it from yesterday, and it happily connected to my home network and is breathing cyan. Apparently it had some residual networks (oops), but I’m even more confused why it wasn’t working last night. I tried recreating the same circumstances by turning off my home wifi network, but I can’t recreate the second of green blinking followed by the SOS 13 code. It just continues to blink green, and unlike last night, I can put it into setup mode. Sooo problem fixed I guess…?

In response to your questions, I’m running the lastest CLI, the Photon is sitting in a bare breadboard, and last night when I tried to engage safe mode, after I released the setup button it restarted, it blinked green for a second, then went into the SOS 13 code. I don’t know if you have any thoughts as to why it works now and what is different, but thank you for the help!