Repeated SOS Hard Fault after DFU Flash

Hello! I started getting a SOS flash while my Photon was connected to my LED strip. I took it out and plugged it into the computer.

I tried to put it in Safe Mode, but it just started SOS’ing again.

I then put it in DFU mode and ran particle update which worked, but still get a hard fault while it’s connected solely to my computer.

Any ideas?

Could you try flashing Tinker back onto it in DFU mode? In the CLI, issue particle flash --usb tinker. That should get a known working firmware back on there.

I tried that yesterday several times (in addition to particle update). It flashes successfully, but reboots and goes back to flashing SOS + hard fault.

That is really strange, since Tinker is a known good app, which shouldn’t cause any errors. Did you update your CLI before trying the particle update? If not, could you give that a try by doing npm update -g particle-cli? Then, try the particle update once more.

Could you post your CLI output when USB flashing Tinker?

Full output of running all of that and reflashing with both particle update and particle flash --usb tinker:

➜  ~  npm list -g | grep particle-cli
├─┬ particle-cli@1.8.16
npm ERR! missing: node-wifiscanner@git+, required by spark-cli@1.4.2
npm ERR! extraneous: node-wifiscanner2@1.1.0 /usr/local/lib/node_modules/spark-cli/node_modules/node-wifiscanner2
npm ERR! invalid: tsd@0.6.0-beta.5 /usr/local/lib/node_modules/tsd
npm ERR! extraneous: minichain@0.0.1 /usr/local/lib/node_modules/tsd/node_modules/minichain
➜  ~  npm update particle-cli
➜  ~  npm list -g | grep particle-cli
├─┬ particle-cli@1.8.16
npm ERR! missing: node-wifiscanner@git+, required by spark-cli@1.4.2
npm ERR! extraneous: node-wifiscanner2@1.1.0 /usr/local/lib/node_modules/spark-cli/node_modules/node-wifiscanner2
npm ERR! invalid: tsd@0.6.0-beta.5 /usr/local/lib/node_modules/tsd
npm ERR! extraneous: minichain@0.0.1 /usr/local/lib/node_modules/tsd/node_modules/minichain

// Put Particle in DFU mode

➜  ~  particle update

> Your device is ready for a system update.
> This process should take about 30 seconds. Here goes!

! System firmware update successfully completed!

> Your device should now restart automatically.
> You may need to re-flash your application to the device.

// Reboots and flashes hard fault
// Put Particle in DFU mode again

➜  ~  particle flash --usb tinker
Found DFU device 2b04:d006
checking file  /usr/local/lib/node_modules/particle-cli/binaries/photon_tinker.bin
spawning dfu-util -d 2b04:d006 -a 0 -i 0 -s 0x080A0000:leave -D /usr/local/lib/node_modules/particle-cli/binaries/photon_tinker.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Deducing device DFU version from functional descriptor length
Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 3952
Download	[=========================] 100%         3952 bytes
Download done.
File downloaded successfully

Flash success!
➜  ~  

// Reboots and flashes hard fault

Since this is most obscure, I’ll just suggest a stab in the dark.
Could you try to wipe the WiFi credentials by holding the SETUP button for 10+ sec and then see if the device stays in Listening Mode or also goes SOS?

I plugged it into my laptop and accidentally did DFU mode instead. When I unplugged to reset, it started to smoke. I think it maybe shouldn’t be plugged in again.

Is there a Photon RMA process or something?

Try hello [at] and reference this thread, but how unplugging (or DFU mode) possibly cause this?
Did you have any extra circuitry attached?

Nope. Just the USB cord connected to my laptop. It smoked while it was connected, though I pulled it out in a hurry after that. Sent an email. :smile:

1 Like

Can confirm that it definitely should not be smoking. There is indeed an RMA process. Someone from Particle will be on your support request soon!

1 Like

How are the LED strip connected to the Photon? Usually whenever magic smoke come out of any electronic, it is due to a large electrical current. Depends on the size or driver IC on the LED strip, it might have a very low electrical impedance which would draw a large current and break most IC device out there.

Do you have the data sheet of that LED strip? How did you connect the LED to the photon?

Hi Peter!

I can provide that info if it’s useful, but the smoke happened after repeatedly being plugged into solely my computer with a working MicroUSB cable. The SOS started while connected to the LEDs, but the smoking wasn’t for a while after that. (It’s also worth noting that another Photon connected to the same LED circuit headers with no circuit changes has been functioning fine).

We can help you do a quick check of your circuit connection if you can provide the information on your LED circuit. Sometimes stress damage to electronic don’t occur immediately and only found sometimes later.

Sure! It’s pretty simple. 5V 10A power supply, power and ground wired to both Photon and LEDs. LED data goes into a digital pin on the Photon. There’s also a switch, though I think that was not yet soldered in so it’s irrelevant.

Is the power supply ON and connected at the same time as the USB?

It happened once to me in that setup that my computer fan started spinning faster and the computer heating up. Once removed the computer stopped the fan and got cooler. I think there’s a Diode somewhere to prevent the current from flowing to the computer when there’s a power supply connected to VIN. But I don’t know if that works as I expect or not.

My computer USB port got toasted. I can’t get reliable power to my iPad or iPhone after that incident. I can’t confirm that was the photon or not, but I am guessing that both things connected at the same time is not a good idea. :blush:

Nope! The SOS started while connected solely to the LEDs (where another Photon is currently sitting in the same circuit without problems). When the magic smoke appeared, it was just USB and nothing else.

1 Like