Hard Fault (red flash SOS) [Solved]


I was playing with my Sparkfun Redboard (based on particle P1) and stumbled upon a “#1 Hard Fault” SOS signal https://docs.particle.io/guide/getting-started/modes/core/#red-flash-sos

And I can’t get rid of it…

I have tried the factory reset mode but it never showed up (always blinks yellow, never blinks white).

I have tried to manually update the firmware (to 0.4.7) using dfu-util commands but noting changes, the same problem happens https://github.com/spark/firmware/releases

What should I do?

Thank you

@michael3, factory reset is no longer supported on the Photon/P0/P1/Electron. The blinking yellow is DFU mode. Do you have Particle CLI installed on your PC? If you do, first make sure you have the latest installed (npm update -g particle-cli). You can then put your P1 in DFU mode and run particle update. Afterwards, you can flash over Tinker. :smile:


Thx for the advice.

I have successfully updated and flashed my device however it does not change the ouput: once rebooted, the device emits a SOS signal again…

~/dfu-util/src$ sudo particle update

> Your device is ready for a system update.
> This process should take about 30 seconds. Here goes!

! System firmware update successfully completed!

> Your device should now restart automatically.
> You may need to re-flash your application to the device.

and then

~/dfu-util/src$ sudo particle flash --usb tinker
Found DFU device 2b04:d008
checking file  /usr/lib/node_modules/particle-cli/binaries/p1_tinker.bin
spawning dfu-util -d 2b04:d008 -a 0 -i 0 -s 0x080A0000:leave -D /usr/lib/node_modules/particle-cli/binaries/p1_tinker.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device...
ID 2b04:d008
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 4740
Download    [=========================] 100%         4740 bytes
Download done.
File downloaded successfully

Flash success!

Still no luck… I don’t see the normal “breathing LED”, just the SOS signal again.

How does the device behave when putting it into Safe Mode?
Can it then enter breathing magenta or does it also SOS?

After Safe Mode, it still shows SOS, no breathing magenta…

Maybe you got corrupted WiFi credentials.
There was a firmware that somtimes killed the credentials when adding more than two sets of WiFi credentials.

With 0.4.7 it should be possible to reset them by press and hold SETUP for at least 10sec after rapping reset during the green blink phase (before you get the SOS).

BTW: Do you mean in Safe Mode*** or after dropping out of it


Have you ever found a solution to this SOS condition - as I have exactly the same issue and cannot get out of it.

I am also facing similar kind of problem. Photon device stuck into SOS.
here is link of video: https://www.youtube.com/watch?v=nhQrofxDswc

Please, suggest any solution for it.

@Brus, the SOS code is showing a hard fault which is most likely caused by the code running on the Photon. Have you tried putting the Photon in SAFE mode and flashing Tinker or blink (known good apps) to it?

@peekay123, tried to enter into safe mode but no success. Again it moves into SOS.

@Brus, can you get it to DFU mode?

@peekay123,yes able to get into DFU mode.

@Brus, if you have Particle CLI installed (if not, then please install it) then with the device in DFU mode try:

- particle udpate
- particle flash --usb tinker

@peekay123, Getting following error

device manager shows

@Brus, did you install the Zadig driver required for DFU to work?

@peekay123, Thanks I have successfully connected Photon to particle cloud. Wonderful, at last it is breathing cyan!! :grinning:
For others don’t worry i will make a thread of how to successfully put particle in DFU-mode and burn tinker code in it on windows 8.1 platform. (coming soon… :innocent: )


Some thing worh noting for Windows users - the easiest way to put the device into DFU Mode:

Press Win+r and execute

mode COMx 14400

where COMx is the COM port assigned to your device :wink:

And flashing Tinker, as Paul said above

particle flash --usb tinker

This topic was automatically closed after 4 days. New replies are no longer allowed.