Particle Cannot get out of Hard Fault [RESOLVED]

My particle electron is in the SOS Hard Fault state, while updating the firmware yesterday, the system began this blinking. I cannot get into Safe mode like others.

Unfortunately I also cannot use particle update… I get the following error when in DFU mode

!!! I was unable to detect any devices in DFU mode…

Your device will blink yellow when in DFU mode.
If your device is not blinking yellow, please:

  1. Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.

  2. Release only the RESET/RST button while continuing to hold the MODE/SETUP button.

  3. Release the MODE/SETUP button once the device begins to blink yellow.

I just downloaded the dfu-util

When I run particle flash --usb tinker, it downloads but goes back to the Hard Fault state. Need help!

Thank you!

What OS are you running?

macOS

Got it working. Thanks

1 Like

Twhat did you do to resolve this? No matter what I do, can’t get one of mine out of hard fault.

I’ve tried tinker, upgrade, even tried the doctor.

I can get it to DFU mode, but safe mode, wifi reset, and normal boot always go to hard fault.