Unable to escape Hard Fault

Hi, I am having a problem escaping hard fault mode on my photon. It has worked okay for some time but it consistently drops out of it’s wireless connection. Whenever it does this I have to reset it or it would blink green (Search for internet) forever (It was not a wifi problem as I have a P1 device working perfectly on the same network). Today i tried resetting it and it went into the hard fault mode(blinks Red SOS then 1 more red blink). I have tried updating the firmware and installing the blink binary via DFU mode but it just goes back into the hard fault mode. I have also searched and tried some other solutions I found here on the discussion board to no avail. Can I please get some help on how to solve this issue? Thank you in advance.

Welcome to the Particle Community!

Have you tried reflashing the system firmware over dfu?


Thanks for the reply. Yeah I have tried flashing the firmware and tinker with every method available but it just goes back into the hard fault mode.

@milikuru, if you have the latest CLI installed, put the Photon in DFU mode and try:

particle update
particle flash --usb tinker
1 Like

I am using CLI v 1.17.0. I just tried this method again but it still goes back into hard fault mode. I also just noticed my photon is always showing up online on the particle build IDE even when completely disconnected from power. Could this be part of the issue?