SOS Hard Fault directly from packaging

I just bought a few Photons to add to my collection. One of them is SOS #1 (Hard Fault) straight out of the box. I’ve tried to force a DFU firmware update to 5.2.0 + re-flash of tinker (The two firmware flashes and tinker report successful in the command line) but upon boot it flashes white for maybe 1/10th of a second, then immediately returns to SOS Hard Fault.

Seems like maybe a factory faulty Photon? Is there anything else I can do to troubleshoot or fix it? I’ve tried using a 5v bench power supply to rule out power issues, and I was able to use DFU successfully to upgrade another Photon just to validate my procedures were correct.

Sorry about that Jerad,

You can email our support team to get things sorted out ASAP.

The fact that your are able to upload firmware via DFU indicates that the bootloader is working fine. It sounds like some form of memory corruption in the firmware for it to hard fault at startup.

Thanks mohit. Particle support was able to get me sorted out, they do believe it is a faulty device.

1 Like

Fantastic! Sorry for the false start, but we’ll be sure to get you a working device ASAP.