Photon SOS (+1 hard fault)


#1

Hi
I have a photon since a few months that stopped working. Now having time, I grabbed and tried to recover it. I know there are a lot of post about SOS hard faults, but none was helping me.

After powering the Photon LED is white for about 500ms (or what ever… you now what I mean). After this it immediately turns to SOS +1 (hard fault) code.
I have no posibillity to come to “safe mode” as the SOS seems to interrupt the procedure. Also it seems to be impossible to turn on listen mode. However I can switch to DFU mode (yeah!).

I tried the following:
particle update (successfull, but still SOS+1)
particle flash --usb tinker (successfull, but still SOS+1)
particle flash --usb system-part1-0.7.0-photon.bin (followed by a …)
particle flash --usb system-part2-0.7.0-photon.bin (followed by a …)
particle flash --usb tinker (successfull, but still SOS+1)
particle doctor (not sure if successfull. It flashed the firmware, flashed the doctor, but SOS+1 occured after the message if it should scan for nearby WiFi).

particle version reports “1.32.4”

So, I’m out of ideas… Is the device maybe broken?
Thanks for any ideas
Pix


#2

I fear so. I’ve had a couple devices which I probably didn’t treat to gently (:pensive:) behaving the same way and even with flashing them via JTAG I could not get them back to working order.

No idea what the actual cause is, but I’ve since used them as display items rather than working devices :sunglasses:


#3

Thanks ScruffR for your quick response.

At least I got the confirmation from an experienced user, that I most likely killed a photon :persevere:. No idea how this happend, but hey… can’t change it now.

Thanks again :sunglasses:
Pix