Particle Photon stuck in Boot Loop with Hard Fault

I have a Photon that was working fine and all of a sudden went into what appears to be a boot loop with an SOS message of red blinking lights that according to the documentation is indicating a hard fault. I have tried using the DFU with particle update through the CLI as well as the online device restore tool and it fails once the device is trying to start back up into normal mode after writing new files. Basically this thing is a brick unless I can get some help on how to get it going again. Im fairly tech savvy but really struggling with this one! Anyone else got an ideas or other things to try?

Will not boot into safe mode, or normal mode. I can only get it into DFU mode manually.

Thanks!

Hi, @krjones6725!

I'm sorry, sounds like a real hardware fault and it's possibly dead. But we can try a last thing. Are you able to put it into listening mode and perform a serial inspect? If yes, please share the output.

Can you get into listening mode from DFU? If not, then no because it won’t load into anything other than DFU. Trying to load normally or into safe mode just results in a boot loop with the SOS LED message.

Thanks
KRJ

No problem. If you can only use DFU, you can try this:

particle udpate
particle flash --usb tinker

This will force the installation of the thinker firmware, hopefully after that, you can re-flash your device with your own FW.

Hey Alberto,

I have tried that process already several times with no success. When I run the particle update command, it appears to be doing something, gets to 76% complete and the log message then states that it’s trying to switch into normal mode. The device then reboots, and immediately goes back into the boot loop with the SOS LED signature. Thus, I can never make it far enough to complete the particle update process and can’t get the tinker firmware to flash.

Any other thoughts?

Thanks!
KRJ

Hi!

Sorry, sounds like it might be due to a corrupt flash. I fear your device is really broken :frowning:

I think I saw this (on a P2) and got fixed with a flash of an older device firmware. Try flashing 5.3.1 or 5.3.2. I was never able to flash anything more recent than 5.3.2

From the CLI:

particle update --target 5.3.1

Or using the online device restore tool