[SOLVED] Photon SOS Red LED 13 Blinks

I am working on a school project and when I brought the three photons I am using to my house for installation, one of them began acting up. When I power the device on it goes through the flashing green light and then blinks SOS with a red LED, thirteen blinks, and then the SOS blink again. It will continually repeat this process and I cannot connect to the WIFI. How do I resolve this?

@pswanger, 13 blinks after SOS indicates a stack overflow. Have you recently made changes to the code running on the Photon that is acting up?

No I have changed the code. It was working fine on the school network last Friday, brought it home today to install the project and it started acting up as soon as it was plugged in.

Have these devices been working on you home network before? How is that one Photon powered?

This is the first time using this device at home. It is being powered via USB to my computer.

@pswanger, if it is the first time then you need to setup the WiFi credentials for you home WiFi so it can connect. The light pattern you see may be due to the fact that it cannot find the school network and it has not been configured for any other network. Do the other Photons do the same thing when powered?

Also, make sure to use a good quality USB cable just to be sure.

I am using the USB cable provided with the photon maker kit. The device will not enter setup mode to be able to connect it to a new network.

@pswanger, what version of DeviceOS are your Photon’s running? Did you follow the instructions for putting your device in listening mode?


It will not enter listening mode, or safe mode.

@pswanger, if possible, power your Photon from another source like an apple phone charger and report your results.

No change in results.

Not to be patronizing, but are you sure you know how to get into Safe Mode correctly?

This has been a bizarrely difficult thing to teach clients when I need them to troubleshoot something.

Hold down setup and reset, release reset, release setup when the LED begins flashing magenta, correct?

1 Like

That should be the right sequence. What does it do when you try to put in in safe mode?
If possible, a short video clip of the symptoms and modes might prove helpful.

Although it will not enter safe mode, it will enter DFU mode. However “particle update” and “particle doctor” do not work when using the CLI

Did you try the long-hold that clears all wifi credentials?


Problem solved. I had to download and flash the files for the firmware over USB.