The server has failed to process the request on time

I have been trying to compile my code. But I ended up error saying “The server has failed to process the request on time. Please try again”. Please kindly look into this issue.

Same thing happening. Am not able to compile the code. Have tried so many times, still no response from the WEB IDE. Please kindly look into the issue.

Same thing happening. I have been trying to compile my code so many times. But I ended up with the same error saying “The server has failed to process the request on time. Please try again”. Please kindly look into the issue.

Have you tried logging out and in of Web IDE?
Does the same happen when you run incognito mode?
What browser are you using? Try another one.
Could your firewall blocking ports?
Could your browser settings prevent some code execution?
What does the browser console report?

I have moved your other two posts over here since double-posting is not received well.

Thanks for your reply.
Yeah I have tried logging out and in WEB IDE but same error.
And I’m using Mozilla firefox browser. I’ve tried in Chrome also, but same error repeated.
Need check in incognito like you said. I will check and let you know.

1 Like

Maybe you can also provide a project snapshot to check whehter it’s due to some coding issue.
Also double check that you have selected the correct platform and system version.

Hi @Creators,

Can you tell us a bit more about your app? Size of the app, which platform / system firmware version are you compiling for?


Tried incognito mode, but same error.
I am using photon device, the version that I’m compiling for 0.6.3.

Hi @Creators,

Chances are, there is an error in your code that is triggering an error that’s not getting parsed correctly, or the source code is very large, and the compile is taking too long. Lets move to a private message so I can get more details.


I am facing the same issue and tried the methods you have mentioned but still I’m facing the same issue … How could I resolve that?

Hello @Dave
Could you help me out of this I have been getting the issue even while I am compiling and flashing with the sample code…

Thank You.

Hi @geethika,

You could try compiling locally with Workbench ( ), or I’ve found that sometimes cloud compiling with the CLI has a better success rate than the web IDE. I’d download your sources if you’re using the web browser, and try with the CLI ( ).


Hi @Dave,
Thank You for your reply I have started using the workbench but I couldn’t sort out why I’m getting the error while we are using the IDE. Thanks for your support.

Have you shifted what internet access point or location you are on?

For example, when I am at my office the page is not accessible due to network security restrictions put in place and when I am on travel, such as now in South Korea, I have to use my VPN to get access to the wed IDE otherwise it won’t load.


Hello @kolbi,
I have checked in my working location as well as in my home network in incognitive mode but getting the same issue, but using the vpn in working location is not the correct way right? So, trying to use the workbench.
Thank You, for your reply.