WebIDE: Server has failed to process the request on time

Hi all,

I’ve searched the forums for this error, and found various topics about it. Most offer as resolution ‘to clear browser cache’ which did not help for me.

For the first time again in a few months, I’ve opened up the Particle WebIDE to flash a series of Photons I have. I’ve noticed that I can compile and flash exactly 1 time, after which I get the error when compiling:
“The server has failed to process the request on time”.

I need to hard reset the cache of my browsers, and then again, I can compile and flash only once.
I’m using Windows 10, and am compiling and flashing for Photons with 1.0.0 firmware.

What have I tried:

  • Used latest Chrome (updated yesterday) and latest Firefox.
  • Used incognito windows. Same problem in those.
  • I’ve opened the project “Blink an LED”. Same problem.

UPDATE: Edge seems to work slight;y better but scrolling does not work here…

Happy to hear

Have you tried clearing the Web IDE cache? Go to Settings; there 's a button there for it.