Spark web IDE outage?

I’ve been experiencing intermittent issues with the web IDE for a few weeks where it never fully loads (and thus doesn’t load in the code). Sometimes it finally loads after > 1 hour of sitting there. I’ve been trying unsuccessfully since 10am this morning to get the web IDE to load. (Yes, I’d like to copy my project code out of the cloud and into the new local Spark dev IDE).

When this happens, it just sits at the loading spinner forever. Occasionally it results in an “Application Error” message from the web server. I’ve cleared all browser data/cookies/etc, restarted browsers, tried it in Incognito Mode (just to make sure no weird cookies), tried it in Safari, etc. Tried refreshing the page load after a few minutes, etc. The result is the same in all. No dice. I really don’t think it’s me, but I am out of ideas here. E-mailed support on Fri and haven’t heard anything back.

Is this happening to others today (Sun 11/23)?

1 Like

I have seen this before with certain browsers, particularly chrome where I can’t seem to ever fully clear all the cookies.

Try chrome in incognito mode and see if that helps.

Just tried logging in and everything seems fine :wink:

We noticed some issues on Sunday and are continuing to monitor the web site. We suspect a small memory leak in the website, so we bumped up the server size quite a bit while we’re tracking it down. :slight_smile: