Can't log into website - ssl issue?

I’m having an issue logging into the website. If I go to https://www.spark.io/login and type in my email and password, the web IDE appears to be loading (white spinner in the top left corner) for about three seconds, and then it just brings be back the login page. I know my username and password are correct because I do not get the “Invalid username or password.” error.

Thanks,
Alex

@AlexMiller:

Both pages load and I can edit/flash/build in the :spark: WebIDE. I think it could be something wrong with your client. Maybe my first steps could are

  • close the browser, open it and try again
  • clear the browser cache and try again
  • Try a different browser on your system (if available)
  • reboot (last chance)

Hope some of this could help you!
clyde

I tried in Chrome, IE, and Firefox after clearing the cache and cookies, but it still did not help. I then tried IE again and it actually worked, but only for a few minutes.

Thank you for your help!!!

1 Like

Hi @AlexMiller - sorry it’s not quite working for you. Do you know how to open up the javascript console? If so, could you open the console while you load the website? Hopefully that would shed some light on why it’s not successfully loading.

Hi @zach

Here is the console output when I try and log in and the page goes back to the login page without saying my username or password is wrong. Let me know if there is a way I can format this log better on this forum.

Thanks for your help!!


2014-07-23 07:57:36.005DEBUG: ------------------------------- application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.021DEBUG: Ember.VERSION : 1.0.0 application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.022DEBUG: Handlebars.VERSION : 1.0.0 application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.022DEBUG: jQuery.VERSION : 2.0.3 application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.022DEBUG: ------------------------------- application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.186generated -> controller:loading Object {fullName: “controller:loading”} application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.205generated -> controller:loadingSidebar Object {fullName: “controller:loadingSidebar”} application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.355
GET https://www.spark.io/libs.json 403 (Forbidden) application-93f63877e5d917633e4aa2250d8cc0f0.js:30
2014-07-23 07:57:36.362DEPRECATION: Action handlers contained in an events object are deprecated in favor of putting them in an actions object (error on Spark.ApplicationRoute:ember611)
at Object.e [as triggerEvent] (https://www.spark.io/assets/application-93f63877e5d917633e4aa2250d8cc0f0.js:73:25306)
at g (https://www.spark.io/assets/application-93f63877e5d917633e4aa2250d8cc0f0.js:73:17615)
at h (https://www.spark.io/assets/application-93f63877e5d917633e4aa2250d8cc0f0.js:73:19875)
at p (https://www.spark.io/assets/application-93f63877e5d917633e4aa2250d8cc0f0.js:67:28860)
at null. (https://www.spark.io/assets/application-93f63877e5d917633e4aa2250d8cc0f0.js:67:29460)
at r.trigger (https://www.spark.io/assets/application-93f63877e5d917633e4aa2250d8cc0f0.js:67:26620)
at https://www.spark.io/assets/application-93f63877e5d917633e4aa2250d8cc0f0.js:67:28223
at Object.n.flush (https://www.spark.io/assets/application-93f63877e5d917633e4aa2250d8cc0f0.js:67:10084)
at Object.n.end (https://www.spark.io/assets/application-93f63877e5d917633e4aa2250d8cc0f0.js:67:11311) application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.364
Error while loading route:
Object {readyState: 4, getResponseHeader: function, getAllResponseHeaders: function, setRequestHeader: function, overrideMimeType: function…}
application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.367
GET https://www.spark.io/apps.json 403 (Forbidden) application-93f63877e5d917633e4aa2250d8cc0f0.js:30
2014-07-23 07:57:36.370
GET https://www.spark.io/access-token 403 (Forbidden) application-93f63877e5d917633e4aa2250d8cc0f0.js:30
2014-07-23 07:57:36.383
GET https://www.spark.io/cores.json 403 (Forbidden) application-93f63877e5d917633e4aa2250d8cc0f0.js:30
2014-07-23 07:57:36.414
Uncaught # application-93f63877e5d917633e4aa2250d8cc0f0.js:73
2014-07-23 07:57:36.955DEBUG: ------------------------------- application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.972DEBUG: Ember.VERSION : 1.0.0 application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.973DEBUG: Handlebars.VERSION : 1.0.0 application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.973DEBUG: jQuery.VERSION : 2.0.3 application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:36.973DEBUG: ------------------------------- application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:37.144generated -> controller:login Object {fullName: “controller:login”} application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:37.148Transitioned into ‘login’ application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:37.194generated -> route:forgotPassword.index Object {fullName: “route:forgotPassword.index”} application-93f63877e5d917633e4aa2250d8cc0f0.js:66
2014-07-23 07:57:37.372DEBUG: For more advanced debugging, install the Ember Inspector from https://chrome.google.com/webstore/detail/ember-inspector/bmdblncegkenkacieihfhpjfppoconhi application-93f63877e5d917633e4aa2250d8cc0f0.js:66

Did this ever get resolved? If not, @jgoggins may be able to take a look at it and see what’s (not) going on.

No it has not been resolved yet. Thanks for keeping it alive!

It does look like some kind of security issue (with the 403 errors), potentially coming from bad cookies. What happens if you try it from an incognito window in Chrome?

@zach
Incognito mode is blocked for me in Chrome :frowning:
I am able to use the private browsing mode in firefox, but am still facing the same issue, even after clearing cookies.

Thanks,
Alex

I would suggest testing on a separate machine to isolate the issue :slight_smile:

1 Like

Agreed. Is there anything else unique about your set-up that might point to the source of the issue? Where are you located, and what kind of computer are you using? I’ve really got no idea what’s going on here, since I haven’t heard of anyone else encountering this issue.

1 Like

None of us are able to access it on our network (several people). I’ve had our security group take a look at it and do packet captures and so far they don’t know either.

I did find one weird workaround though…If I enter in my email address and a bad password, I get the standard ‘bad u/n or p/w’ message, but then if I try again with the correct password it appears to actually work! If I try a different email address it does not work, I must use my email address with a bad password first, then if I do it again with the correct password it does appear to work.

Thanks!

Does anyone have an idea what this means? If I enter in my email address, with a wrong password I get the normal “bad password/email” message. But then if I change the password to my correct password it works and lets me log in.

Why do I have to do a false entry first?

I don’t think you need to do that.

Try entering the correct credentials the first time and see what happens?

Are you using a proxy server for your network connection? Sometimes proxies that are meant to cache web traffic and improve local bandwidth do bad things. Often a proxy rule can be added that marks a site so it is never cached. Proxies can also map requests for libraries like jQuery to local “safe” copies which can fail.

Or are you connecting through some sort of net nanny that tries to block certain sites? Getting the site whitelisted by the net nanny provider would be the best way then.