login issues

I’m following the Getting Started instructions and I’m at the point of logging in to the IDE at When I tried to log in with the email and password that I use here, it told me I had an invalid username or password. When I tried to reset my password, it told me “User Not Found.” So I went to create a user with the same email and it said the email was already taken.

Not sure how to proceed…

I’m getting numerous issues with logging in via the SparkJS package in the past hour. Possibly related?

ETA: we’re seeing a lot of this when attempting login: spark-login-error - {"code":"ETIMEDOUT","errno":"ETIMEDOUT","syscall":"connect"}

Further update: I’m getting a timeout error when I attempt to login via the CLI.

The Build IDE and the forum don’t (yet) use the same accounts. You’ll thus have to create separate accounts for those. This will hopefully be ‘merged’ at some point in the future.

Have you tried the ‘forgot my password’ on the email which was said to be taken? Perhaps you’ve already created an account under that email address.

@cmn_jcs, I can login to with the javascript without issues, same for the CLI. Are you sure your internet isn’t being flaky?

@Moors7 Pretty sure it’s not a flaky internet problem. On the server I’m trying to get going again, I can ping it without issue, and I can ping out of it without issue. On my local machine and two remote servers, I’m very intermittent ability to log in (JS and CLI), and frequent issues with doing anything in the CLI (can’t test the JS because I can’t log in).

ETA: neither the servers nor my local machine can ping

Hi @cmn_jcs does not answer pings so that is not a good test. A lot of internet hosts have that turned off due to some nasty denial of service attacks.

I had trouble just now too, but it seems to have been fixed in the last few minutes.

Thanks. I guessed as much after I tried it.

ETA: unfortunately, still having issues.

As I said in the original post, I tried the reset password link and it told me a user with my email didn’t exist. But trying to create one tells me that it is already taken. This is the only account I’ve ever tried to make here.

I’m still unable to get an account on using my email. Here’s what I get: tells me "email already taken" tells me "invalid username or password" tells me “user not found”

So I am left with no path forward other than creating a new email address somewhere, which seems egregious. Who can I contact to get this cleared up?

1 Like

Hi @mouser,

That code was updated recently, and it looks like there is a strange issue that is impacting your user account. I’ll open an urgent ticket with the engineer who made those updates and ask them to look at it first thing tomorrow morning. Sorry about the delay.


Thanks @Dave, I appreciate you looking into it.


1 Like

Hey, @mouser

I just wanted to ping you and let you know that we’re looking into the issue. It’s working for me and a lot of people, but we do see errors in the logs, so it’s not definitely not working for a few people. We’ve got to dig in a little deeper, but we’ll get it solved.

I’ll keep you posted, I just wanted to let you know we’re looking at it actively. PM me if you’ve got some urgent needs.



1 Like

im having the same issue as @mouser

i need access to stop my cellular plan as the three months have already ended, so i cannot create a new account as mouser does.

Have you tried the forgot password option below the LOG IN button?


yes i have, i just couldn’t send the 3 images

I actually have tried in 4 computers more than 5 networks(home, job, starbucks, a coworking space…) so im pretty sure is not a problem on my network or computer. and i have even tried in my smartphone(android), and my brother’s iphone

@KyleG can you refer to the right person to check on the account privately?

1 Like

Hi @ratgr. It seems like your email was there twice in our email system and it got confused. We fixed it and you’ll be able to send the password reset email now.

1 Like

thank you, i already have access to my account, eventhough it did send me the password reset email it still sends me the error ( not that it matters to me anymore but maybe another user trying to get his password reset may freak out a little), just for you to know there is still a (maybe unimportant) issue there.