Sparkulator (aka WebIDE) currently not functional? [SOLVED]

At the moment I cannot compile anything on the WebIDE (tried serveral sketches that used to build).
Message: Error: Could not compile. Please review your code.

I checked the Status page, but everything is green - is there a way to report such a thing, rather than opening a thread? (e.g. a “Report incident” button on the Status page)

Pinging @Dave and @jgoggins

Web IDE Sparkulator is failing for me too. Usually this is some bucket that is overflowing and needs to be emptied on the server cloud, but it is always good to log out and log back and/or try Chrome incognito mode.

1 Like

Thanks for the response, but log off/on didn’t work, neither did Chrome incognito.

I just wanted to do some quick tests about the DeviceID thing from the other thread :wink: so we meat again

Hey Guys,

Thanks for the FYI, @Dave and I are on it. Will ping this thread when we’re back up.

1 Like

Okay, we’re up.

There was a bug in the IDE build farm code that somehow deleted the workspaces where user compilation occurs.

@ScruffR I like the idea of a “report incident page”, will chat with @tavares about this and see if I can come up with some ideas to pursue that.

Thanks for reporting this guys and thanks for your patience,



Actually the bug was in how the build farm was resetting the workspaces. Somehow it was resetting to a local version of the compile-server2 branch, instead of the origin version, causing it to try and use old code, which is why the builds were failing. I’ve updated the scripts to make sure it grabs the origin branch in case the local one is ever modified, which should fix the issue.



@Dave and @jgoggins - I’m sorry to be a pain, but now we seem to have a new problem :wink:

Error: 400. Please try again later. If the issue persists, please report to

Would be quicker, or post here?

Hi @ScruffR,

The build farm is up and humming, it might be something in your code it’s rejecting. What are you building?


@Dave, the flem :wink: must have been spat out already, now the code compiles just fine with no alterations to it.

But thanks anyway!