Spark Core will not connect over usb

I was not able to connect my particle board to my Windows 7 Machine via the app it was getting stuck at connecting to the Particle Cloud. so I tried to do it over usb following the particle docs.. In which it tells me to go to the device manager and the Particle should be under Other Devices before the driver is installed, and I cannot find it under that category in the Device Manager. What is the next thing I should try?


What specifically are you intending to do via USB?

I am just trying to figure out why it isn’t picked up by my device manager.

Have you got your device in one of the modes mentioned in the docs you’re refering to?

Yes it is breathing cyan for sure, and the document suggests manually claiming the core when that happens.

No, in connection with DrvMgr the docs talk about listening mode (blinking blue) and DFU mode (blinking yellow) - or if you’ve got some firmware running that makes use of the USB serial connection (which it doesn’t out the box).

If your device is already breathing cyan, you’ve already got it connected to your network “via the app”.

Thank you for the clarification. I have the spark core in blinking blue now, however I am getting the same result.

Do you hear the Windows “Attach device” sound when you set the Core into blinking blue (listening mode)?

If not, try a different USB cable and maybe a different USB port.
In case your cable was faulty, your USB port may have got deactivated for self protection, till the computer gets power cycled.

It does make that sound when I set it into listening mode, so I assume to some degree it knows that it is there. I have tried with many cables and all ports, even other windows 7 machines.

And you are absolutely positive that the device does not show up in DevMgr - neither under USB Devices nor under Ports (COM & LPT) nor Other Devices?

Could you provide a screenshot with these branches expanded?

1 Like

So I am really new to this and it took me a minute to find how to set it to DFU mode. Now the DevMgr can see it!

Thank you for the help!


That’s what we old folk are here for - we like our devices and want you to like them too :wink: