[Spark core] Common issues

@kennethlimcp it did not. had my hopes up there for a second. still flashing green after running through those steps.

Weird… Can you also do particle flash --factory tinker? I presume your CLI is the latest version…

Did you try connecting with a mobile hotspot?

@kennethlimcp i have done particle flash --factory tinker and my cli is the latest, yup. i also did try connecting to a mobile hotspot, yup.

lol. quite the frustration when you have two cores where one is fine and one is not.

@kennethlimcp Looks like it’s my board based off the comment, the variant I have doesn’t have the antenna. Not sure why there’d be a variant of a cloud-based system without an antenna but glad I’m not simply an idiot.

That one was meant to have an external uFL antenna, which should be more reliable/offer better performance than an onboard one. The Photon has an integrated RF switch, which allowed for a single board to be used for both variants.

3 Likes

hi, i have a very old core that behave odd. sometimes it can connect but sometimes it enters endless cycle between flashing green, cyan and then oranges three times.
I try to run particle keys doctor, but what frustating me is DFU util can’t open my core. although on device manager the core is already listed as CORE DFU.
i try re-installing DFU driver many times but no success. I already try :

  1. changing USB port and cables
  2. delete and re installing the DFU driver
  3. update CLI
  4. Running command prompt as administrator

I already try with photon also in the same PC, the DFU has no problem reading the photon in DFU mode.
am I missing something? please help…

What does the command dfu-util -l give?

Hi Ken,
i put 2 devices on my laptop. 1 is core (cannot open DFU device) and the other one is photon (Found DFU)
this is the screenshot :

while on the windows device manager, both core and photon are already listed as DFU, although on different tab.

I noticed on your tutorial you are using driver lilusbK (v3.0.6.0), but i use lilusbK (v3.0.7.0).

Can you use the same driver for the Photon for your Core?

NOW IT’S WORKING!!!

actually i believe i use the same driver as the photon before (lilusbK (v3.0.7.0)
but then i try to replace with another driver that is listed in zadig. I end up using WinUSB (v6.1.7600.16385)
and its working.

now i have a question, is different core device use different driver to be recognized in windows? because in your tutorial you are using lilusbK (v3.0.6.0) right?

I’m not certain but a newer driver version should work, though. The only reason that i used that version is related to the date when this was written. :slight_smile:

I have been able to setup and connect, my core; I think; connect to it via the android app, and connect it via usb. updated the Win10 usb driver to show it as a port or dfu depending on mode.

It seems I’m stuck on two places. (maybe the same place, from two view points)

The first one, if I do the quick setup of the core, it connects via Wifi, and then gets stuck in magenta LED status. I cannot tinker with it, and the app drops connections to it the whole time.

The other place, in the usb/CLI I can also install/setup the core, but as soon as I set it up, it freezes when I get to "Press ENTER when your core is excitedly shouting rainbows"
It never shouts anything, just stays magenta. If I enter past this point. I can name it. and this was the last message I got:
"You’ve successfully setup your core (my_core_name) (xxxxxxxxxxxxxxxxxxxxxxxx)"
But it’s still stuck in magenta.

If I press the reset button, it breathes cyan for 5 seconds, then reverts back to solid magenta.

If I put it into DFU mode, and use the command “dfu-util -l” I get “Cannot open DFU device 1d50:607f”

And running “particle flash --factory tinker” just tells me “No DFU device found” even though the LED is blinking yellow.

At this point the device manager is showing under “OTHER DEVICES” “CORE_DFU”

Can you try installing the DFU-driver?

Thanks a million… It’s alive!!!

Must have missed that step somewhere!

Will this work for Photon also? Photon == Core ?

It won’t. The photon has no CC3000, thus no patch needed. Furthermore, a factory reset isn’t available on a Photon, so you won’t be able to do that (shouldn’t be necessary either).
Rather, depending on your issue, give safe mode a try first and flash known good code (Tinker/blink an LED). if that for whatever reason doesn’t work, hook it up in DFU mode and issue ‘particle update’. Then do DFU once more and issue ‘particle flash --usb tinker’.
Depending on what your issues were, this should get you back to a factory~ish state.

1 Like

With my Photons I seem to end up in a state where they just wont connect to wifi anymore. I run the particle setup and set my wireless configuration. The chip restarts, flashes green a few times, then starts flashing light blue cyan. You can then see 3 very fast red flashes and it keeps flashing light blue cyan.

I can pull out a new photon, run the same configuration and it works fine. So i don’t understand the difference in the state of these photons? Keys registered before? Does the account matter? If you wipe the wifi with 10 seconds on the setup button, does that unclaim the device form an account too ?

Maybe that’s the difference? I have 2 Photons stuck in this state, where I just cant get them to connect.

Gavin: That’s a weird pattern. Blinking green to blinking cyan then several red/orange blinks usually means a keys problem. However, typically it goes back to blinking green after that. If it goes to blinking blue, on the Photon it usually means No Wifi Configuration. Here’s what I’d try:

Put the Photon into Listening mode (blinking blue) by holding down SETUP until it blinks blue. Then issue the CLI command:

particle identify

Save the Device ID; you’ll need it later.

Put the Photon into DFU mode (blinking yellow) by holding down RESET and SETUP. Then release RESET while holding down SETUP while it blinks magenta, until it blinks yellow, then release SETUP. Then issue the CLI commands:

particle keys doctor <deviceid>
particle keys server
particle flash --usb tinker

Now hold down the SETUP button until the Photon blinks blue, then keep holding it for 10 seconds or so until it blinks blue rapidly. Then issue the CLI command:

particle serial wifi

If you know your Wifi network SSID and authentication type (WPA2, for example), I prefer to just enter it manually instead of auto-detecting it.

That should get you pretty close to a factory fresh condition and hopefully that will fix it.

1 Like

Don’t forget the ‘particle update’ to make sure the system firmware is up to date.

Furthermore, making sure the CLI is up to date before attempting this whole procedure wouldn’t hurt either.

Nope, that’ll just erase the credentials on the device. The source of thruth for ownership lies with the cloud, not the device.

1 Like

Thanks guys! That seems to have worked. Both Photons are out of their non-wifi connection mode.

Now if I had the same luck with my Electrons. They seem to end up in this Dim D7 light mode. Not responsive to any button press… Red light will come on indicating charging the Lipo, but Main indicator light is off.

Maybe I should move threads

1 Like