[Spark core] Common issues

The OS you are using has no effect on the patching of the Core.

You might want to verify that the network is compatible with what the core might require.

CC3000 patch suggestion fixed my issues here after patching I invoked particle setup again and did the network registration over usb particle serial usb, thnx and cheers! I run ubuntu 14.4.

1 Like

Is there any way to fix it if I can’t connect it to USB? I have a v1.0 Core and the USB port broke off some time ago. Now it just flashes green, even after factory reset with the buttons.

Sadly, you need the USB port to put it in DFU mode… Unless you have a STLinkV2 or programmer shield around.

I do not… that’s unfortunate. Thanks!

Can you not resolder the USB socket (or use the USB pads on the underside)?

You could cut up an old USB cable and solder the wires to the pads on the underside.

I don’t know that I can solder something as small as the usb socket, but I can give it a try since it won’t hurt anything at this point.

I wasn’t aware of USB pads on the underside. I can look into that option as well.

Now that I have it in front of me, I’m not seeing any obvious usb headers. Do you have a link to docs or an image?

These two should work:
https://docs.particle.io/datasheets/photon-datasheet/#pin-out-diagrams
https://docs.particle.io/datasheets/photon-datasheet/#recommended-pcb-land-pattern-photon-without-headers-

Yes, I see pads on my Photon, but I need to fix a Core.

I was able to fix it by holding the usb cable & connector onto the Core in the right place for long enough to flash the firmware. I’m back up & running. Thanks!

4 Likes

I tried following this procedure for a V1 core.

particle flash --factory tinker //Gets no errors
particle flash --usb cc3000 (will blink magenta and eventually revert to yellow) // Blinks magenta and never stops

Any suggestions?

I have a white Spark Core v1.0. I get through all the DFU flashing and resetting and updating and no matter what, once I enter my wifi credentials, the core refuses to connect to my network. I have successfully connected a different Core to this network with no issue so I am concerned it’s this Core.

Any advice that doesn’t involve telling to me to through all these same steps again would be helpful.

Maybe you can tell us what’s the rgb led light sequence?

the RGB LED light sequence on every step listed is what you’d expect based on that step. once i enter in my credentials it flashes green without stopping. which leads me to try to the steps again.
i’ve tried the deep update and reflash

particle flash --usb deep_update_2014_06

this perpetually flashing green, from what i gather, is an issue with not being able to connect. as i said, i’ve gone through this with another core and it works fine. this is not a network issue.

i appreciate the quick response.

i’ve gone through the process again at my office using this core. still no luck. the light sequence is as expected for each stage until i get to connecting to the network then it simply flashes green.

again i was able to connect with my other core so the network is not at fault. any help is appreciated.

I’m curious to know what happens with the core RGB led status after you do particle flash --usb cc3000?

It should blinking magenta and eventually revert to blinking yellow. Does that happen?

yes. it blinks magenta and eventually reverts to blinking yellow. it blinks in the colour expected at each stage of the sequence you listed. only once it reaches attempting to connect to the wifi network does it infinitely flash green.

Interesting. Which means the CC300 patch is “sticking”. Can you also do:

  • particle flash --usb cc3000_1_14
  • particle flash --usb tinker
  • particle serial wifi

and see if it works?