Wifi Connectivity issue with Spark Core 1.0 -- SOLVED

I am facing WiFi connectivity issue with Spark Core 1.0. I have tried following

  • DFU UTIL and flash CC3000

  • Factory Reset and Tinker with following sequence

    particle flash --factory tinker
    particle flash --usb cc3000 (blinks magenta -> yellow)
    particle flash --usb tinker
    particle flash --usb tinker

and then when I connect to WiFi

I have detected a Core connected via USB.
? Would you like to continue with this one? Yes
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: [rescan networks]
? Select the Wi-Fi network with which you wish to connect your device: dlink-2328
? Security Type WPA2
? Wi-Fi Password xxxxxxxxxxxx
Done! Your device should now restart.
? Press ENTER when your core is breathing CYAN

After this LED blinks green… Tried with WPA as well and it does not work. I have another Photon that connects quickly.

Hmm… Can you try doing particle flash --usb cc3000_1_14?

I tried that. The link blinks yellow. Then I did particle flash --usb tinker followed by particle setup wifi but same issue persists. Still keeps blinking green

Hmm… interesting… Can you setup a mobile hotspot on your phone and see if the core connects to it?

I have 2 different networks in my home but Particle CLI only detects one network which is quite strange.

Windows 10 detects all of them so does RPI too.

This is the output of dfu-util

dfu-util 0.7-msvc

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Opening DFU capable USB device...
ID xxxxxxxxxx
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
DfuSe interface name: "Internal Flash  "
Downloading to address = 0x08005000, size = 25240
Download        [=========================] 100%        25600 bytes
Download done.
File downloaded successfully
TransitionInvalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
ing to dfuMANIFEST state

Flash success!

@kennethlimcp any help on this? Still struggling to get this going… Tried DFU util, tinker… everything :frowning:

The issue is that the Core is unable to connect to your wifi network?

Yes @kennethlimcp .

Home WiFi 2.4Ghz is using CH 12, USB Hotspot is CH 1 and Mobile Hotspot is CH 11

This is the use case:

  1. Photon Board: Able to connect to all networks - Channel 12, 1, 11 and is working fine
  2. Spark Core 1.0: Able to connect to Channel 11 but not others. Keeps flashing Green after entering credentials

All use WPA2 and signal strength is strong (around -56 dBm to -36 dBm)

Hmm… So using the mobile hotspot with channel 11 it connects fine? What happens if you change the channel for the mobile hotspot?

@kennethlimcp did try that now. Mobile Hotspot connects on CH 1 (on which USB Hotspot doesn’t) too

So it seems like some settings on the USB hotspot and home network is not allowing the core to connect properly.

Is there a b/g mode only? n mode might cause some issues with the Core

@kennethlimcp - I agree, but how does the Particle board work with these WiFi networks? Is there any tool to diagnose the difference?

The CC3000 and BCM43362 wifi chipset are entirely different and it’s hard to compare it directly

Folks, the Core only works with channels 1 to 11. If you recall @kennethlimcp, at maker fair, particle had made a special firmware that worked on channel 14. However in North America that channel is not allowed so that is why it’s not in the release firmware.

1 Like

@peekay123, good point! Though the USB hotspot is channel 1 and it didn’t work too.

@kennethlimcp @peekay123 I tried changing the Hotspot to use Mixed Mode 11b/g with CH 7 but still it does not connect.

This is quite confusing

@Punit, what router are you using and do you have MAC address filtering enabled?

OK. I managed to crack this…

Looks like Spark Core needs 2.4Ghz 802.11b/g CH 1-11 whereas Photon is ok with 2.4GHz 802.11b/g/n CH1-13

Now what happens is that if the Router has CH 12 (or higher) and the hotspot/repeater is configured for CH1-11, the hotspot/repeater sometimes will do transmission on CH12 which causes the issue.

1 Like

And it’s in the docs too