[SOLVED] Unknown issue with Photon EDIT: Photon cannot connect to cloud


#21

Try the command again, and select ‘no’, then enter the information manually?


#22

My motherboard is running through ethernet, could that be an issue?


#23

If you haven’t got a wireless network card, it might be hard to detect wireless networks…
That said, entering the information manually, like I mentioned in my previous post, should work.


#24

So I have tried that and this is what happened

C:\Users\Atique>particle setup
                  _   _      _        _
 _ __   __ _ _ __| |_(_) ___| | ___  (_) ___
| '_ \ / _` | '__| __| |/ __| |/ _ \ | |/ _ \
| |_) | (_| | |  | |_| | (__| |  __/_| | (_) |
| .__/ \__,_|_|   \__|_|\___|_|\___(_)_|\___/
|_|                     https://particle.io/

> Setup is easy! Let's get started...
> It appears as though you are already logged in as atique_chowdhury@hotmail.com
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

> I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We'll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You will lose your connection to the internet periodically.

! PROTIP: Some computers may require Administrator permissions for my automagical Wi-Fi scanning capabilities.

! OOPS: I was unable to scan for nearby Wi-Fi networks (-___-)

? We can still proceed in 'manual' mode. Would you like to continue? Yes

! PROTIP: Manual mode will prompt you to manage the Wi-Fi connection of your computer when it's necessary.
! PROTIP: To proceed, you will need to be able to manually change the Wi-Fi connectivity of your computer.
! PROTIP: Your Photon will appear in your computer's list of Wi-Fi networks with a name like, Photon-XXXX
! PROTIP: Where XXXX is a string of random letters and/or numbers unique to that specific Photon.

! PROTIP: You will need to know the password for your Wi-Fi network (if any) to proceed.
! PROTIP: You can press ctrl + C to quit setup at any time.

> Obtained magical secure claim code.

? Please connect to the Photon's Wi-Fi network now. Press enter when ready.

> Now to configure our precious Photon

! PROTIP: If you want to skip scanning, or your network is configured as a
! PROTIP: non-broadcast network, please enter manual mode to proceed...

? Would you like to manually enter your Wi-Fi network configuration? Yes
? Please enter the SSID of your Wi-Fi network: Chowdhury Home Network
? Please enter your Wi-Fi network password (leave blank for none): ********
? Please select the security used by your Wi-Fi network: WPA2 AES
> Here's what we're going to send to the Photon:

> Wi-Fi Network: Chowdhury Home Network
> Password: ******** 
> Security: WPA2 AES

? Would you like to continue with the information shown above? Yes

> Obtaining device information...

> Obtaining device information...

> Obtaining device information...

#25

aaaaandddd it’s still obtaining :expressionless:


#26

I was thinking of the particle serial wifi command, since the Particle setup command can be somewhat unstable.
Give that a try?


#27

@atiquechowdhury, do you have a wireless router? If you do, then the SSID of “Chowdhury Home Network” will most likely not work with the photon due to the spaces. As a general rule, you should use “_” (underscore) as a spacer instead of an actual space character.


#28

That’s applicable to anything digital. Using spaces give you more issues than it’s worth. Just sayin’ :wink:


#29

@peekay123 @Moors7 Well this is awkward, I have tried underscores because it does make sense to use it. However it is still obtaining information, could this be a problem with distance to the router? The router network reaches far and right now both the laptop and phone beside me shows full connection. Does photon have a problem with distance?


#30

What colour is your Photon showing while it’s doing this?


You can also use CamelCase for your network ChowdhuryHomeNetwork


#31

Blue flash (listening mode) I believe. I get in to this mode everytime by holding setup button for 3 seconds. Otherwise it flashes green


#32

A question to you gentlemen, during the setup, it says “Please connect to Photon’s wifi network now and press enter when ready”. How does one do that when computer is in ethernet? Do I just press enter? I have been pressing enter in previous tries

@Moors7 @peekay123 @ScruffR


#33

Have you tried particle serial wifi in Listening Mode?

You’d need to disconnect from the wired network (either via software or unplug), but with above command you won’t need to do this


#34
C:\Users\Atique>particle serial wifi
? Should I scan for nearby Wi-Fi networks? (Y/n) y
? Should I scan for nearby Wi-Fi networks? Yes

! serial: Unable to scan for Wi-Fi networks. Do you have permission to do that on this system?

C:\Users\Atique>

#35

I have switched over to the laptop as I think it is better to have WiFi capabilities on the motherboard for this setup operation. I will give update in few minutes

Thank you for all your help this far, I really appreciate it
@ScruffR @Moors7 @peekay123


#36

Try it with No :wink: for above reason


#37

I have just tried that on the laptop, it says

!Something went wrong: Serial timed out

#38

Thought I had mentioned that before :wink:
If you haven’t got a wireless card it doesn’t make sense, whatsoever, to have it scan for wifi. It’s like trying to breathe underwater. There’s no air, so you’re not going to find any…

First, erase all your previous credentials by holding the setup button u till it starts flashing blue quickly (10s). After that, it should be in listening mode. Then, try particle serial wifi and Mae sure you enter the information manually. Do not have it scan, do not have it use ‘magic setup’, enter it manually.

(Was there a reason you couldn’t use the mobile app?)


#39

I’ve somehow managed to go as far as verifying credentials right now after you mentioned the app. Last night it wouldn’t go past connecting to cloud

This is what the blinking light looks like

EDIT:
Just tried this

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Atique Chowdhury>particle setup
                  _   _      _        _
 _ __   __ _ _ __| |_(_) ___| | ___  (_) ___
| '_ \ / _` | '__| __| |/ __| |/ _ \ | |/ _ \
| |_) | (_| | |  | |_| | (__| |  __/_| | (_) |
| .__/ \__,_|_|   \__|_|\___|_|\___(_)_|\___/
|_|                     https://particle.io/

> Setup is easy! Let's get started...
> It appears as though you are already logged in as atique_chowdhury@hotmail.com

? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

> I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We'll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer
is connected.
! PROTIP: You will lose your connection to the internet periodically.

? Found "Photon-99WG". Would you like to perform setup on this one now? Yes

! PROTIP: You will need to know the password for your Wi-Fi network (if any) to
proceed.
! PROTIP: You can press ctrl + C to quit setup at any time.

> Obtained magical secure claim code.


! I am unable to automatically connect to Wi-Fi networks (-___-)

? We can still proceed in 'manual' mode. Would you like to continue? Yes
? Please connect to the Photon-99WG network now. Press enter when ready.

> Now to configure our precious Photon

! PROTIP: If you want to skip scanning, or your network is configured as a
! PROTIP: non-broadcast network, please enter manual mode to proceed...

? Would you like to manually enter your Wi-Fi network configuration? No
? Please select the network to which your Photon should connect: Chowdhury Home
 Network
? Please enter your network password (or leave blank for none): sumavilla
> Here's what we're going to send to the Photon:

> Wi-Fi Network: Chowdhury Home Network
> Password: sumavilla
> Security: WPA2 AES

? Would you like to continue with the information shown above? Yes

> Obtaining device information...
> Setting up device id *******************************
> Requesting public key from the device...
> Setting the magical cloud claim code...
> Telling the Photon to apply your Wi-Fi configuration...
> The Photon will now attempt to connect to your Wi-Fi network...

> Configuration complete! You've just won the internet!
? Please re-connect your computer to your Wi-Fi network now. Press enter when r
eady.
! It doesn't look like your Photon has made it to the cloud yet.

? What would you like to do? Check again to see if the Photon has connected
! It doesn't look like your Photon has made it to the cloud yet.

? What would you like to do? (Use arrow keys)
> Reconfigure the Wi-Fi settings of the Photon
  Check again to see if the Photon has connected

[EDIT 2] I have also tried it manually, same conclusion. I have also tried it with underscores, same conclusion as well :frowning:


#40

I have done particle serial wifi and cmd returned that Photon is restarting. The photon wouldn’t stop blinking all colours now. What does this blink mean?