[SOLVED] Particle Won't Connect to University WiFi. (cause: firmware 7.3)


#1

Hello,

My 8 Particle Photons will not connect and I am worried that they will never be able to because they are now unclaimed.

Problem
My particle photons cannot connect to a 2nd WiFi network, and are also now unclaimed.

Background:
I am in a University setting with 2 networks: a student network (let’s call it SCHOOLNET) that requires registered MAC addresses and a guest network (GUESTNET) that any device can connect to, but only for 1 week.

For a test demo, an assistant set up each photon on his personal particle Build account (“PERSON”) instead of our group build account (“GROUP”). He used the particle command line interface and each photon was connected to GUESTNET. The demo worked great.

Description
After the 1 week period, the photons could not get internet bc their GUESTNET week had expired. So we registered the MAC addresses on SCHOOLNET. At the same time, we unclaimed them from PERSON’s particle build account via build.particle.io web interface so that we would be able to claim them on the correct GROUP account when the photons got internet.

We then used the Particle-CLI to re-configure the Photons’ wi-fi settings to use SCHOOLNET. However, none of the 8 particles can connect, and simply blink green over and over. The 8 MAC addresses show up in SCHOOLNET’s registered MAC database, so that is not the issue. I also have ~15 previous Photons that are still working just fine.

Attempted Solutions

None of these worked:

  • Trying GUESTNET again
  • Clearing the Wi-Fi settings by holding the MODE button until the lights flashed blue quickly. Then use ‘particle setup’ to re-configure into SCHOOLNET
  • Putting the device into DFU mode and manually pushing a firmware.bin
  • Putting the device into DFU mode and using ‘particle doctor’ to refresh everything. I did not reset the Keys in the last step because the warning scared me:

! Resetting keys for a device you do not own may permanently prevent it from connecting to the Particle cloud.

Is there any way to claim a particle photon Offline? The online documentation suggests otherwise. When i use ‘screen c’ to check the photon’s claim status, I can see that the device was successfully unclaimed by PERSON, but I cannot claim it by GROUP until the particles get internet access :frowning:

Have I bricked all 8 of these photons?


#2

Just a thought… Have you verified that SCHOOLNET allows access to the Particle servers? You could be experiencing blocked access as opposed to a bricked device.


#3

I have ~15 other photons that are working just fine on SCHOOLNET, so I don’t think it is blocked access.


#4

The best way to troubleshoot this is to flash the photon cloud debug firmware by USB and capture a log by USB serial. That will show what step is actually failing in far more detail than the blinking pattern.

The instructions are here:


#5

A simple way to get your devices reclaimed without all the obscurity of WiFi networks you have no direct control over is to just connect the devices to a WiFi you actually have control over.
The probably simplest way would be to use your mobile phone as hotspot, connect to that and continue the claiming process.


#7

Thanks for the useful tool. It didn’t help me this time but I can see this being quite helpful in the future.


#8

Thanks ScruffR. That was a very smart suggestion that helped my claim my test device, and prove that it is indeed a network issue. Now to go wring the necks of IT department…


#9

I have solved the problem. The solution was to manually downgrade the firmware from 7.0 to 5.5, establish a proper WIFI connection to SCHOOLNET, and then upgrade the firmware back to 7.0

For some reason, the university authentication system did not like to initialize with the newest firmware version (0.7.0) when my photon was trying to connect. Right out of the box, the Photons were running an older version (5.3 or 4.7, I do not remember now) which played well with both SCHOOLNET and GUESTNET.

Under a GUESTNET connection, I flashed the out-of-box photon to 7.3, at which point the system got stuck in wifi purgatory when the guest connection expired.

The solution was to manually downgrade the firmware to 5.5 by putting the Photon in yellow dfu mode and using

particle flash --usb system-part1-0.5.5-photon.bin
particle flash --usb system-part2-0.5.5-photon.bin
particle flash --usb bootloader-photon.bin

Once the photon was running 5.5, it was able to connect to SCHOOLNET. And then via particle.build.io, I was able to flash a 7.0 version of my script just fine.


#10

What is 7.3?
The most recent official release is 0.7.0 and the most stable release before that for Photon was 0.6.3 and for Electron 0.6.4.


#11

I have a sensor where I want to leave a particle device at my clients’ location to try them for a week and play with to resolve usability issues as they come. So I set up the device at my location I do not want to leave my phone with the client,
I am thinking perhaps there is a script that can run asking for username and password. I have a Touch Display attached to the device All I have to do it give user option to type in the password at the touch display that talks to particle io to connect to the Internet via Guest-WIfi that is OPEN but requires browser authentication
Another option is to put the device in MANUAL_MODE Since the Device does not require the Internet to function. Just unplug the device at my location walk into to clients location plug the device and it works. . ITs a whole new viewpoint than entertaining them with an explanation.


#12

That would be called a captive portal and these are not supported on Particle WiFi devices.


#13

Ok Got it, Captive Portal are not supported … Thanks
What about regular HotSpot , How can I connect to regular hotspot without using Phone as HotSpot.
I do have Boron so Perhaps I can use Internet-Boron–Argon–Xenon-Sensor So it works anywhere anyplace anytime… Right ? Cellular Charges may apply if the data exceeds 3MB per month
But then I really do not need Argon I can just have, Internet-Boron-Xenon-Sensors Unless I am using large about of Xenons Argon does not serve any purpose right ?


#14

Don’t quite get the question.
If it’s a “regular” hotspot/access point then the connection would not look any different then with your mobile hotspot.


#15

What I wanted to ask is If I wish to connect to a WIFI rounter (Regular Hotspot before phone started to work as hotspots) that has free Internet connection without the password option.


#16

And what I was saying is that it does not matter whether it is a “regular hotspot” or your your phone acting as hotspot.
You’d connect to either of them exactly the same way.

A WiFi network without password would be an open network and these have been supported since the beginning.
However, if you want to connect to a captive portal - which I’d not see as a “regular hotspot” - then you are out of luck as these are not supported.


#17

I have Argon setup to connect to wifi router gateway, Already I want to change that to Phone hotspot What is best way to do that, without removing the device and adding back again, Just to change the gateway, I saw there is nothing in Particle io App that allow one to change the setting, How about command line using Particle-CLI ?


#18

If you mean add another AP credentials then I normally just press and hold the mode button until the LED flashes dark blue then release - this puts the device in serial mode and whilst plugged in to micro USB and with a serial terminal open type W a response SSID: will be shown - you then enter the details as directed.


#19

Ok that worked

I was doing it differently I was doing particle usb list then particle mesh create <Argon-Device_Id> that gave me an Error message about USB not found I upgraded the particle-CLI to 2.0.1 but the error was there. It may be because I have visual studio installed with particle dev plug-in and also particle dev install so may be the usb command of particle is rounted through visual studio first then particle CLI Here is the detail link if Particle Dev team needs it https://github.com/particle-iot/docs/blob/master/src/content/support/particle-devices-faq/mesh-setup-over-usb.md