Particle Photons randomly disconnected from network and won't reconnect

I had two particles on my home wifi network working just fine since March/April of this year.

For some reason yesterday (no changes to them in months), they both started blinking fast green. But my wifi network hasn’t changed at all and all my other devices are connecting fine as normal. Firmware 1.2.1 on both. I recognise this is a pretty old firmware - so it could be related to that somehow…?

For one of the photons, I unclaimed it and then went through the setup process again (holding down the button to get to slow blinking blue, wifi network created (Photon-xxxxxx), and going through setup on my iPhone. I go through ‘yes’ to claim ownership. I get completed checkmarks for all steps, except the last one (verify device ownership), which fails. I then get a 'setup failed. And the light goes back to blinking blue. And the device hasn’t been claimed. I’ve tried connecting to a wifi hotspot on my phone and the same issue as with the Network.

Ideas? Do I need to wipe, reflash the latest firmware and push my code again?

I’m hesitant to do that if I don’t have to only because I vaguely recall that I ended up on this firmware as higher firmwares were causing issues with my code. This was a fun DIY home project done back in March/April - so apologies my memory isn’t that clear on it :slight_smile:

Edit: Found the reason I was on 1.2.1, this post: Issue with multiple instances of Particle.subscribe() using same handler above OS 1.2.1

I can obviously head down that path if needed…but hoping the hive mind has some ideas!

Thanks You.

v2.0.0 does allow you to register the same handler for multiple events again.

Unclaiming an already claimed device never helps resolve such issues. You only ever unclaim a device when you want it to be claimed to some other account.
BTW, if you hadn’t unclaimed the device you still could have gone through the mobile app setup procedure and when the final step failed, your device would still have been claimed to your account just fine :wink:

When the device still manages to connect to the cloud you can claim it via CLI or Web IDE. But to be sure the device stays online while claiming I’d put it in Safe Mode for that.

Thanks, I’ll check out v2.0.0 :slight_smile:

A bit more digging and came across this thread - [SOLVED but hopefully not the last word] Photons lose connection to wifi—any ideas? - and the 2.4GHz vs. 5GHz with the same SSID seems to be the issue. I can’t quite pin down exactly why it started now, but so far splitting off the 2.4GHz network and having my photons connect to that has done the trick.