Unable to claim a Photon

I lent a Particle to a friend. He claimed it successfully a couple times, but now we are both unable to claim it. The Photon receives it’s network credentials (either via App or CLI) and it connects so all is apparently fine, but it’s not able to change owner. This works fine for all the other Photon’s I have, so it’s just this one.

What could cause this?

Try doing particle update followed by particle flash --usb tinker both while in DFU mode. Then, give the app another try?

And if the app doesn’t want to claim it, you can do it via Particle Build or CLI too.

Figured it out. If a device is claimed by a company, nobody outside the organization can claim it :smile:

If they unclaim it, I can grab it.

Yup, that’s by design - this bit of info would have made a difference in answering :wink:

Standard method of connecting did not work for me on the 4th Photon
[https://youtu.be/fcEgXfnlUFg]It gives Error on the Android App)
So I tried Particile CLI but unable to claim it has all 24 digits as inteigers Is that a problem ? reason is the webIDE will not allow me to claim it

  • Your CLI is not most recent. It should currently be up to 1.38.0
  • You should run particle update to get your Photon to 1.0.0 (via DFU Mode)
  • After that run particle flash --usb tinker (in DFU Mode again) - no need to have the device claimed for that
  • To claim the device it needs to connect to the cloud (breathe cyan or magenta)
  • Then you can claim it via particle device add <youDeviceID> or via Web IDE adding the device there as shown here
    Unable to claim Photon. Repeat Title
1 Like

Actually forgot to mention this I have change my ISP and router so before it was Suddentlink now it is Century link. So even the Photon was was working previous (via suddentlink) is flashing greenlight (Not connected to the Internet)
So it is Currently NOT connected to the cloud. Because I am not getting an option on Photon to enter my new SSID and password So I tired it with the APP you see in theyoutube video link the at 1:53 in the video I get option to retry and it continues in the same loop What should have happened is I should have got an option to select my networklike it shows in the video at 0:30 RIGHT Before Step 1, that is where I am stuck, I did try to DFU and particle update and it was success but it did not upgrade it to 1.0 it is still 0.7.0 for some reason, Here is the screen shot as of 2-18-2019 at 2:30pm EST -

THE ISSUE IS NOW Resolved When all else fails use PhotonSetup.html that is downloaded from setup.particle.io

thanks for all the help and information. I believe the 1.0 may be in beta and not in production so no issue there

Thank you ScruffR

Have you tried putting the Photon into Listening Mode and run particle serial wifi - without using any of the auto-detect features?

However, you still have the old version of CLI.

No, it’s not. It was officially released as default version 1.0.0 (without any rc extension).
There already is a 1.0.1-rc tho’

1 Like

OK I like the Particle CLI now I can go to a any Starbucks with my particle photon and latop and be able to connect to Internet via public Wifi using particle serial wifi it, Now I have more options to do customer demos using public wifi. Thanks ScruffR

Please post the link because the firmware upgrade page https://docs.particle.io/support/troubleshooting/firmware-upgrades/photon/ Even though has a link to Latest Firmware Release it is 0.9.0 (Gen3) That too for MESH not for Photon ?

1 Like

Ya, no. The internet access at Starbucks require that you agree to their terms. The Photon can’t connect to these types of portals.

Never mind I found it on Github https://github.com/particle-iot/device-os/releases/tag/v1.0.0
Just for validation is there a side by side comparision of P1 and Photon harware and firmware ?? Here is the thread Is there a difference between Photon and P1 regarding SPI?

So what are my option for onsite customer demo ?? Can Photon Do Tether like PhotonWifi-Cellphone-Internet if PhotonWifi-StarbuckWifi-Internet is NOT current option for it to work ?

A phone hotspot should work fine for connecting your Photon to.