[solved] No WiFi connection but also deep update not possible

hi
i have get an spark with a L3D Cube. So the spark works with the default programs but its impossible to connect to the WiFi. So i have read that it maybe is a good idea to flash the deep update. I installed the spark line command on Ubuntu 12.04 like its told under “install on Ubuntu”. The line command works as i can get out (via USB connect" the id of the spark. So i tried to update but get this error:

FOUND DFU DEVICE 1d50:607f
checking file  /usr/lib/node_modules/spark-cli/binaries/deep_update_2014_06.bin
spawning dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000:leave -D /usr/lib/node_modules/spark-cli/binaries/deep_update_2014_06.bin
invalid dfuse address: 0x08005000:leave
Error writing firmware... 

So i don’t know what to do now but for now i can’t do anything with the spark. Did someone have the same issue or an idea what can be done?
thx for help in advance
hape

If you have Spark CLI installed propperly you could try this command

spark flash --usb deep_update_2014_06

@hape,

it’s probably caused by the “leave” syntax that the older DFU version you are using cannot understand.

Try this: dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000 -D /usr/lib/node_modules/spark-cli/binaries/deep_update_2014_06.bin

hi
@ScruffR: have tried your tip and get

sudo dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000 -D /usr/lib/node_modules/spark-cli/binaries/deep_update_2014_06.bin
dfu-util 0.5

(C) 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc.
(C) 2010-2011 Tormod Volden (DfuSe support)
This program is Free Software and has ABSOLUTELY NO WARRANTY

dfu-util does currently only support DFU version 1.0

Filter on vendor = 0x1d50 product = 0x607f
Opening DFU USB device... ID 1d50:607f
Run-time device DFU version 011a
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash  /0x08000000/20*001Ka,108*001Kg"
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
No valid DFU suffix signature
Warning: File has no DFU suffix
DfuSe interface name: "Internal Flash  "

didn’t exactly know if its correct (or how i can control it)
ipls give me a hint whats going on :slight_smile:

thx
hape

PS
the spark blinks the whole time green after reset
hape

AFAIK the missing DFU suffix doesn’t matter, you can ignore this, but I’m not sure if you really refered to my tip, since the command line you quoted there was actually @kennethlimcp 's suggestion.

But since you mentioned blinking green, could it be flashing green like here in the trouble shooting?
http://docs.spark.io/troubleshooting/#troubleshoot-by-color-flashing-green

Some additional reasons why it might not connect to your WiFi:
Possible error in credentials/security settings (set data again - PWD max. 32 char)
The Core doesn’t support 801.11n and higher (change router settings)
The Core can’t connect to channels greater than 11 (change router settings)
Check for radio interference.
If you got a uFL Core, check your antenna.

What security settings are you on (open, WEP, WPA, WPA2, Personal or Enterprise)?

1 Like

hi
@ScruffR sorry to put your name and the tip from @kennethlimcp.

Yes as you mentioned its the flashing green.

But your additional reasons are good because there i have a few issues which are set in my WLAN Router. So i will change the Router and test and then i report if its the solution.

I have WPA2-PSK with AES as encryption (hope this is possible).
Do the chip need SSID Broadcast?

thx for help
hape

WPA2-PSK with hidden SSID is what I use, so it’s fine :wink:

1 Like

yes yes yes it works great - the reason was the channel and the 801.11n protocoll
so thank you so much for helping. Thiese things can be really frustrating. You don’t have an error or something like that it does nothing you seat there and look in this flashing nothing :slight_smile:
thx to all of you but especially to ScruffR

hape

3 Likes