Cannot Flash Locally

I was having a hard time keeping connected to my wifi network so I thought I would try doing the deep update. I never got the message from the web IDE, so I thought I would try to do it from the the CLI.

Now, when I try and run spark flash --usb deep_update_2014_06 it says that “Error writing firmeware… no dfu device found.” When I go into device manager I see ‘CORE DFU’ under ‘Universal Serial bus devices’. I get the same result when in DFU mode (blinking yellow) or listening mode (blinking blue)

I then tried to go back to the beginning and flash s simple blink code to the core with the CLI, but when I run “spark flash core_name_goes_here file_path_to_compiled_code.bin_goes_here” I get this error: {“code”:“ECONNRESET”}. I was able to compile the code successfully from the CLI.

Does anyone have any ideas what I’m doing wrong?


Hi @AlexMiller,

Make sure you are running from an Administrator Command Prompt, and that you installed the DFU drivers (if you’re on Windows)

If you want to flash locally, include the --usb option, so it would read:

spark flash --usb my_firmware.bin



1.) Which platform are you on? Mac OSx or Windows? It seems like the driver might be incorrect though it is listed as CORE DFU…

Also, you need to be in Blinking Yellow for DFU. Listening Mode doesn’t allow DFU.

2.) What is the status of your core right now? Are you able to connect to Wifi? :smiley: