How to install DFU-UTIL?

Core will not connec to cloud. Trying to flash deep update (using nodejs cli). Says dfu-util not installed yet it appears in device manager after following the delete and re-install instruction. Checked this with keys doctor. Any ideas please as losing will to live with this. Just a little history. Core working well for a couple of weeks, doing its thing really well. Decided to use battery shield and that was it, no cloud. All else appears OK.

Sorry to hear about that!. :smiley:

Try powering it with a USB port and see how it goes. Are you on mac or windows?

Also, what is the colour status of the RGB LED?

Thanks for quick reply. Core powered from USB, running Win8.1 on PC.
Flashing yellow when looking for DFU.
Everything looks good apart from continuous flashing green looking for cloud. Tinker doesn’t find core either.
USB comms port works well when flashing blue. Reset and mode switches appear to what they are supposed to. Also done factory reset from buttons to no avail.

Awesome! Thanks for the detailed info.

Do you have Spark-cli installed? If you don’t it’s fine. We can use Dfu-util to perform a CC3000 patch as well.

There are occasions that happened to me as well where the core decides to blink green.

Tinker only works when the core is connected to the cloud and blinking green means not connected to Wifi yet. That explains why :wink:

Yes, Spark-cli is installed, tried cc3000 patch through spark-cli without success before, however now trying to connect comms in this case comm4 will not open port on Spark. Proved terminal emulator on another device.
C:\Users\Graham>spark flash 53ff6c065075535153531587 cc3000
attempting to flash firmware to your core 53ff6c065075535153531587
flash core got error: {“code”:“ECONNRESET”}

If you want to flash via usb, the command is spark flash --usb binaryfilename.bin the command you used is to flash via OTA

OK, this is what I get:
C:\Users\Graham>spark flash --usb c:\spark\deep_update_2014_06.bin
Apparently I didn’t find a DFU device? util said
Error writing firmware… no dfu device found.

Spark is flashing yellow (after both buttons, release reset, release mode when yellow flashes).

Did you install the DFU driver? I wrote a tutorial and you can do a simple search as I’m on the go right now :slight_smile:

DFU installed as per the tutorial using Zadig and appears in Device Manager as:
libusbk USB Devices
in fact the error message says util cannot find DFU device so driver must be there to notice??
Please note also that the usb/serial port will not communicate i.e. serial port not found, with my terminal (proven OK with other RS232 devices).

DFU is another protocol and not Serial.

Hmm. Would you prefer for an exchange since its causing so much hassle? :slight_smile:

I mentioned the USB/serial just for diagnostic information. Tried DFU many times.
A replacement would be really good as Sparky seems to be terminal or at least very poorly.

@harrisonhjones can you assist @Circuitman on the replacement? :wink:

Sending @Circuitman a PM now. Thanks @kennethlimcp