[Solved] Problems upgrading firmware

I’m stuck trying to upgrading my firmware on the spark core. First of all is there somewhere I can check to see what firmware is installed on the spark? And what is the latest?

I keep getting the error:
Apparently I didn’t find a DFU device? util said Error writing firmware… no dfu device found.

I get this error after I type spark flash --factory tinker in the command prompt.

So far the spark is blinking yellow and found in device manager with util drivers as CORE DFU. Drivers are installed.


Re: firmware upgrade: http://support.spark.io/hc/en-us/articles/203108844-Perform-a-Full-Firmware-Upgrade

As for the DFU-device error; that happens to me if the DFU-util isn’t in my PATH (assuming windows). Try invoking the spark cli with a command line window opened in the DFU-util directory.

Let me know how that goes


Do you have a link to the dfu-util? The dfu links on this page are dead.

3rd or fourth post here

I’m closer however I get a Error writing firmware on the spark flash --ubs cc3000.

Nevermind I tried the same command again. I think it worked there.