Can't run firmware deep update - dfu-util help

Spent an hour trying to figure out why my Spark Core does literally nothing (just flashes blue). It’s old, so my best bet right now is to do the deep update. However, dfu-util’s website is down (can’t brew install it). I tried downloading the tar of their source and doing ./configure and make…which work, but now I have no idea what to do next / how to get dfu-util working in the command line so that the update function will recognize it.

Please help!

Thank you,


Flashing blue means it is in Listening Mode waiting for Wifi credentials.

Have you provided the core with the credentials?

I tried with the app, but it never worked - the app just sat in it’s “sending credentials” loop and the core stayed blinking blue

You might want to try the USB method instead :wink:

In case you need dfu-util see this post

Got it connected with the USB method, and once it connected to wifi, it was able to update its firmware on its own.

Thank you!

1 Like