Local Firmware Update Issue (dfu-util -l not detecting Core)

I’ve been trying to update the firmware on the Core since that appears to fix the analogRead issues people have been having. I’ve followed all of the instructions outlined on the Spark Firmware page, but am getting stuck at the end of the process.

I’ve successfully put the Core in the right mode (flashing yellow) and run dfu-util -l in the Terminal window. What should be coming up according to the instructions is

Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash /0x08000000/20*001Ka,108*001Kg" Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=1, name="@SPI Flash : SST25x/0x00000000/512*04Kg"

However, no devices are listed and the only thing that I receive is

dfu-util 0.7 Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc. Copyright 2010-2012 Tormod Volden and Stefan Schmidt This program is Free Software and has ABSOLUTELY NO WARRANTY Please report bugs to dfu-util@lists.gnumonks.org

Any suggestions on how to get the Terminal to list the Core? I have tried both USB ports on my Macbook and that hasn’t helped. I am running OS X 10.9.2.

Does it show up in your device manager?

Hi @braden_s

I have mine on a USB hub on an iMac and sometimes I have to unplug the hub and replug it since the mac gets confused.

You also cannot be running CoolTerm or whatever serial program you use at the same time as this will take over the port.

Some people said they had use sudo dfu-util to run as superuser but I have not had to do that.

I hope one of these works for you!

1 Like

One more thing that may not be obvious! You need to be in yellow-flashing bootloader mode!

Hold down the mode button and tap the reset button. Release mode when you see the yellow flashing LED (typically 3 seconds after releasing reset).

1 Like

@branden_s In your title you say dfu-util -1 where it should be dfu-util -l. In other words, an “L” not a “one”. Could this be causing your problems?

2 Likes

I’ve been using dfu-util -l it looks like I just made a typo during the late night writing this.

As for the other suggestions.

I have it flashing yellow and I’ve tried re-connecting it and using different USB ports with no success. I’ve also tried to run it with sudo which has gotten me the same result.

Good question (I’m not sure why I didn’t think of that earlier). I checked and it is not showing up in the device manager. I have previously used CoolTerm with it so I know at some point the Core was able to connect to the computer successfully.

You might need elevated privileges. Try:

sudo dfu-util -l

I’ve already attempted that with no luck

In my device manager it shows up as “Spark Core with WiFi”. Can I assume you tried a reboot already?

I have an iMac 2012 / OSX 10.9.2 / USB3, I have found on 4 occasions the Spark serial device has disappeared and I need to reboot the Mac to resolve. The device is no longer visible under SystemInformation.app. I have only just moved to local compiles so can’t comment on DFU mode but under certain conditions something strange is going on.

Do you run virtualisation - vmware / Parallels etc and could have inadvertently assigned the spark to a virtual host ?

@bko Yeah I’ve tried several reboots.

@deancs I don’t have any virtualization software installed on my Macbook. My RedBoard connects fine through the USB serial too.

@braden_s what does the device manager say when you enter dfu-mode on the core?

Are you able to hear the ‘connection’ tone when the core enters the mode?

On windows, when i device gets connected as a Serial, there’s a tone which i use to tell whether the machine detected it or not :smiley:

@kennethlimcp I’m on a Mac and as far as I know I’ve never received any sort of audio indication that something is connected via USB serial even when something is successfully connected (like my Red Board). Also, the device manager doesn’t show any device on whichever port the Core is plugged into.

Hi @braden_s

This is going to sound like time-consuming advice, but I would try a factory reset and re-flash the tinker code. I might even do two factory resets back-to-back just to be sure.

I think we have all been assuming that if you see flashing yellow, you are OK on the core, but there are two variables here, core and mac, and it is worth trying to see if the core is involved.

This will ensure that you have known good firmware on your core. From there, I would try the dfu-util again.

Keep us posted!

I don’t know if its the same on a Mac as on an PC.
But one day i connected my Core to an USB 3 port then the dfu-util couldn’t see the core.
And when i connect it to a USB 2 port then it works, Windows sees the device both in the USB 2 and the USB 3 port.
Its just the dfu-util that docent seems to like USB 3, at least on my windows.

2 Likes