Flashing yellow, after reflashing with dfu-util, still cannot update [SOLVED]

My Spark core just flashes yellow - I tried resetting to factory defaults with mode+RST - RST - It flashes white then goes back to flashing yellow
So I installed dfu-util with macports
With the Spark hooked up to (either, tried both) USB ports, dfu-util does not find it (output below)
and About the Mac / System Report does not show the device under “USB”

What a disappointment :frowning:

$ sudo dfu-util -l

dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.

Copyright 2010-2012 Tormod Volden and Stefan Schmidt

This program is Free Software and has ABSOLUTELY NO WARRANTY

Please report bugs to dfu-util@lists.gnumonks.org

Apple owners take note!

So I decided not to sit around whining and instead to blame Apple, since OS 10.9 changed a lot of USB code.
Sure enough, on a Linux netbook lsusb saw the device and dfu-util reflashed it.
It wouldn’t connect to one of my networks but it did just fine on the other so for now I am good.

1 Like

Sigh - well not so good in the end. It seemed to connect, went through a blinking magenta cycle and then
and I launched the app on my phone. I named my Spark and then the app then lost the connection and resetting the Spark went back to the flashing yellow LED.

I tried the RST+MODE-RST reset and it had the same results as before - stuck on flashing yellow. I reflashed using dfu-util again and repeated.

Back to flashing magenta after confirming the name that it found.
After flashing magenta it went to flashing yellow.

After a minute or two the app told me “we have encountered an error. Please check that your core is online.”
So I tried the reset and of course got stuck flashing yellow. I’m going to assume a hardware problem at this point.

One thing I forgot to say
When dfu-util finishes the second command “-a 0…leave” it tells me

File downloaded successfully
Transitioning to dfuMANIFEST state
Error during download get_status

Back to disappointed.
Please help.

and my last update … it now connects, starts flashing magenta and then goes solid magenta.

Which firmware version did you flash? I’m also having problems so I can hardly offer any real advice, but the magenta LED functionality sounds like the cc3000-patch-programmer is running.

I mention this because I have tried to load the patch programmer on my core and can’t get the magenta LEDs.

Whatever the current version is in “factory_firmware.bin” as of last night - there’s no version in the filename and strings on the file does not show anything that stands out as a version or release label.

@raygeeknyc unlikely that what you’re seeing is a hardware issue; if it’s getting through the firmware update (flashing magenta) then the hardware is working fine. can you take a picture or video of what you’re seeing?

if you’re comfortable loading firmware over dfu-util, you can also try flashing the latest master firmware; simply take the binary file that’s in the /build folder of the core-firmware library.

Thanks @zach
Is this different from the file that I have been flashing via dfu-util? Please give me a link to the file you’re describing.

Here’s latest master binary—click “View Raw” to download it:

EDIT: haha, the forum tries to show the link and decides something’s wrong—copy paste that URL into your browser

Hi Zach
The latest firmware seems to be working. When I first claimed the core an error msg flashed on the phone that “we’ve encountered an error” but it went away quickly, before I could read any more. Nonetheless the core went to breathing cyan and I can toggle D7 and make the LED light up so I assume all is well for now.
Thanks for the quick responses.

1 Like