Spark Core: Flashes Magenta -> Solid Magenta; Unable to DFU mode

I bought 2 new cores, and first one I got it to work properly.

Second one however, only flashes Magenta when I initially plugged it in.
When I plug it in, it blinks Magenta for a few seconds, then goes into a solid Magenta colour.

I’ve tried putting into DFU mode and Factory reset but it only flashes Magenta and no other colour…

When I plug it in, it also does not register under “Device Manager”.

Does anyone know if the core is faulty or how to approach this problem?

I’ve tried to search the problem but unable to find anyone with the same problem as I have. As usually
the solution is to put into DFU mode and factory reset and patch to 3300. But since I an unable to do so. I’m stuck.


Can you try a factory reset?

I’ve tried to factory reset using this method:
" Hold down both buttons, then release the RST button, while holding down the MODE button. The LED should begin flashing yellow. Continue holding down the MODE button until you see the Core change from flashing yellow to flashing white."

But it never flashes yellow, just magenta, and never flashes white.

Is there another way to factory reset the device?

Can you post a video of your attempt to factory reset?

Here is the video of what happens when i plug it in as well as what happens when I try factory reset. Hope it helps!

If you deem I didn’t “Hold down both buttons” long enough, I’ve tested the length of holding down both initially to be longer and still did not work. Can upload another video if needed…


That looks as if your bootloader got corrupted.
In that case you may need a JTAG/SWD programmer to revive the device.
We can ping @BDub for that and please open a support ticked with a reference to this thread.

Okay, I’ve submitted a ticket under “unable to set up device” and referenced this thread.

Thank you @ScruffR for helping in this matter, much appreciated.

1 Like