[SOLVED] Electron Serial Timed Out

I don’t know if someone has encountered this on electron before. My electron kit that I just got and was working fine for the last few days suddenly gives me serial timed out error. I have tried all the help in here to no avail. I am on windows 7 64-bit. Here is how I am testing.
C:\Particle>particle --version
1.15.0
C:\Particle>particle serial list
Found 1 device connected via serial:
COM4 - Electron
C:\Particle>particle identify
! serial: Serial timed out
C:\Particle>

I have uninstalled the driver and reinstalled; changed the com port from COM4 to COM2; restart the computer, all to to avail.
Any idea what could be the cause?

Could you try putting your Electron into Safe Mode first and then - when breathing magenta - press SETUP till you end up in Listening Mode and try again?

I have tried this but still getting same error. After getting the RGB LED in Listening mode I ran “particle identify” and still got timed out error.
I even installed the device on a different windows 7 computer but nothing works. The problem is definitely with the device and I am totally stranded. This is a device that has been working just fine and I have already put my first set of code in it and tested. This is how the device blinks when I ran “particle identity” command.

Out of steps that I can’t explain I got it back working. The only think that I have done different is to pull off the battery, bring the device in safe mode and then in listening mode. Then particle identify works

Thanks!

2 Likes

I am having a similar problem where PARTICLE SERIAL IDENTIFY keeps timing out (W10/64)

After some safe modes and resets it changed to the following which seems odd. It reports some information, then can’t open COM4, but I have no problem monitoring COM4 for debug info.

What mode should the Electron be in for SERIAL IDENTIFY to work?

I am trying to ascertain whether I am really running the latest firmware or not…

The strange thing here is that the command retrieves the ID and IMEI but not the firmware version? I think you should try first to update your firmware by getting your device in DFU mode and then run

particle update

particle flash --usb tinker

After this put the device in safe mode and try

particle identify

Normally you would put your device into Listening Mode (blinking blue) for those commands, but if your code uses SYSTEM_THREAD(ENABLED) that might not be enough since some parts of your code can still interfere with the serial connection, so it’s best to first put the device into Safe Mode (breathing magenta) and then into Listening Mode to be sure only the system is running.

Yes, I find that strange, too.
No problem running the update and flashing tinker, per your instructions.

But still no joy with identify - either timed out or the half ID shown above. It is as if identify is attempting to re-open an already opened port.

inserting

Serial.printlnf("System version: %s", System.version().c_str());

into the blink LED example prints the version as 0.5.2 nicely over COM4.

But the mysteries remain…

My firmware for testing now is the blink LED example, so no SYSTEM_THREAD(ENABLED) .
Same results as before after Safe … Listening…

Just to confirm, you’ve got CLI v1.16.0 or higher?

1.16.0